Solved

Tried everything but my battery still won't charge...

My laptop battery does not charge when it's plugged in. No LEDs either. I have an Acer Aspire 5755G.

I changed batteries with no results. I know it's not a problem with the charger because I can start the laptop without the battery. I tried switching it off, removing everything, holding power button for 40sec, putting everything back and stuff like that.

The battery does get charged in some special circumstances. If the laptop is switched off, if I remove the battery and put it back in, it gets charged when I switch it on, but if I remove and replug the charger, it no longer charges. If the laptop is already on and I insert the battery while it is running, it charges but stops again if I disconnect and replug.

Any ideas?
2 answers Last reply Best Answer
More about battery charge
  1. Best answer
    Might just be a defective battery. Try it on a different computer or try a different battery. If it works fine on a different computer then maybe it's something wrong with the charging port. You can probably buy a new battery from Acer off their website, but in order to fix the charging port you'd probably have to go through the RMA process.
  2. Sounds like the charging switch in the laptop might be broken.
Ask a new question

Read More

Battery Laptops Laptop Battery