NO HDMI display for Brand new Build Asus PRIME X370-PRO Motherboard and Ryzen 5 1600 CPU

I cannot get into POST BIOS on my new build, nothing appears on my monitor, and HDMI cable is good.

All system Specs
Prime X370-PRO motherboard
Ryzen 5 1600 CPU
Corsair Vengeance 16GB (2x8GB) DDR4 3200 (PC4-25600)
Nvidia GeForce GTX 970 4gb
650 watt PSU

No error or beeps on startup. LED RAM lights up. The motherboard lights up, the fans turn on and STAY on. The Fans on the GPU are moving. I plugged in a keyboard and mouse and they light up. System is stable and doesn't turn off.

I read somewhere that I have to use a VGA cable to install bios update before using HDMI? I was wondering if this were true before I run to the store and get a VGA cable. I don't have one laying around.
Reply to mattwen
3 answers Last reply
More about hdmi display brand build asus prime x370 pro motherboard ryzen 1600 cpu
  1. Is the HDMI connected to the video card? The Ryzen has no video out for the motherboard video ports.
    Reply to elbert
  2. elbert said:
    Is the HDMI connected to the video card? The Ryzen has no video out for the motherboard video ports.


    I didn't realize the CPU didn't have onboard graphics. So it's plugged it into the GPU (HDMI) but still no output.
    Reply to mattwen
  3. Try resetting bios and check your PCIE power plugs going to the video card. If that doesnt work try testing with just one stick of RAM. Swap to the other RAM if it still doesnt work.
    Reply to elbert
Ask a new question Answer

Read More

No display HDMI ryzen 5 1600 Motherboards Asus Prime X370-PRO New Build