My pc screen goes black and all of a sudden gpu fans start running fast and stays like it until i turn it off

When only Playing games my pc screen goes black and all of a sudden gpu fans start running fast and stays like it until i turn it off. and also if i switch off the pc after shutdown, the first time i on the pc it goes black without goin to any thing. the pc have been built by myself with a help of a friend. it happens since its been built. at first there was a silent annoying buzzing sound in the psu too. been 7 months like this. although i use the pc a few times as i'm busy with work. also the usb drives work only when i plug them before turning on the pc. bought a new bluetooth headphones but the sound keeps interfering. but it works with evry other thing. HELP ME OUT GUYZ.

Below are the details of my pc. please figure out what i have done wrong and I ONLY PLAY CSGO NO OTHER GAMES

CPU: Intel - Core i7-6700K 4.0GHz Quad-Core Processor ($309.99 @ SuperBiiz)
CPU Cooler: Deepcool - CAPTAIN 240 EX 153.0 CFM Liquid CPU Cooler ($85.33 @ OutletPC)
Motherboard: Asus - Z170I PRO GAMING Mini ITX LGA1151 Motherboard ($151.99 @ SuperBiiz)
Memory: Corsair - Vengeance LED 16GB (2 x 8GB) DDR4-3000 Memory ($132.88 @ OutletPC)
Storage: Crucial - MX300 275GB 2.5" Solid State Drive ($99.88 @ OutletPC)
Video Card: Asus - Radeon RX 480 8GB ROG STRIX Video Card ($259.99 @ SuperBiiz)
Case: Phanteks - Enthoo EVOLV ITX Mini ITX Tower Case ($65.99 @ NCIX US)
Power Supply: EVGA - SuperNOVA G3 550W 80+ Gold Certified Fully-Modular ATX Power Supply ($79.89 @ OutletPC)
Operating System: Microsoft - Windows 10 Pro OEM 64-bit ($132.89 @ OutletPC)
Total: $1318.83
Reply to Damn1591
5 answers Last reply
More about screen black sudden gpu fans start running fast stays turn
  1. I would download HWINFO and run it in "status mode" and then play your game for a few moment to see what your CPU and GPU temperatures are indicated in the MAX column, I suspect a possible overheating issue.

    Also at the same time, it is possible it is a ram stick that is the issue, so I would suggest to run MEMTEST86 and see if it find anything. please report soon your findings.
    Reply to The Paladin
  2. The Paladin said:
    I would download HWINFO and run it in "status mode" and then play your game for a few moment to see what your CPU and GPU temperatures are indicated in the MAX column, I suspect a possible overheating issue.

    Also at the same time, it is possible it is a ram stick that is the issue, so I would suggest to run MEMTEST86 and see if it find anything. please report soon your findings.


    running in status mode is not ticking both sensors or summary mode while startup of program right?
    Reply to Damn1591
  3. The Paladin said:
    I would download HWINFO and run it in "status mode" and then play your game for a few moment to see what your CPU and GPU temperatures are indicated in the MAX column, I suspect a possible overheating issue.

    Also at the same time, it is possible it is a ram stick that is the issue, so I would suggest to run MEMTEST86 and see if it find anything. please report soon your findings.


    running in status mode is not ticking both sensors or summary mode while startup of program right?
    Reply to Damn1591
  4. cpu is around 77C and GPU 90C .. those are the max
    Reply to Damn1591
  5. You and your friend didn't install things properly. With that advanced a build, there should be NONE of the issues you listed there.
    Reinstall the CPU cooler properly: It's a watercooler. Considering you never OC'ed your CPU, it's temps should be no higher than 65C-70C

    I'd call any repair shop or a well known guy (ask your friends) and ask them to dismantle and re-assemble your entire setup.

    If you wana do it yourself, search a proper guide on youtube, take everything out, carefully, one by one, keep all the screws out, sorted, and re-assemble it from step one.

    As for your screen going blank problem, your GPU's drivers keep crashing. There can be a few reasons, one being the most common: Overclocking too much.

    Also, did you apply proper thermal paste on the CPU?
    Reply to Achint2000
Ask a new question Answer

Read More

BIOS Power Supplies AMD Shutdown Gaming