Solved

GPU not detected. Cant install drivers

Hi, recently I've bought a pc, but stumbled upon a problem. The PC does not detect by GPC (gtx 1060) and all I can see is Microsoft Basic Video Card or something. I've tried installing the drivers, but apparently my OS isn't compatible, even tho I download a correct version.

My OS: Windows 10, 64-bit, x64
Driver: Windows 10, 64-bit

I don't really know much about PC's and the only thing that comes to my mind, is trying to use Windows Update.
PLZ Help ;-;
Reply to Wanila
3 answers Last reply Best Answer
More about gpu detected install drivers
  1. If you bought prebuilt computer then first make sure you plugin video cable into your gpu, not motherboard.
    Also right click windows icon (on the bottom left), then press Device manager. Then click on Display adapters, does it show gtx 1060?
    Reply to Makentox
  2. Makentox said:
    If you bought prebuilt computer then first make sure you plugin video cable into your gpu, not motherboard.
    Also right click windows icon (on the bottom left), then press Device manager. Then click on Display adapters, does it show gtx 1060?


    It is connected to GPU, also I checked Display Adapters and it still only shows Microsoft Basic Graphics Adapter. I think I'll also try installing some older version of NVIDIA driver, maybe then it'll work?
    Reply to Wanila
  3. Best answer
    Wanila said:
    Makentox said:
    If you bought prebuilt computer then first make sure you plugin video cable into your gpu, not motherboard.
    Also right click windows icon (on the bottom left), then press Device manager. Then click on Display adapters, does it show gtx 1060?


    It is connected to GPU, also I checked Display Adapters and it still only shows Microsoft Basic Graphics Adapter. I think I'll also try installing some older version of NVIDIA driver, maybe then it'll work?

    Well windows 10 will always take care of drivers which i dislike personally so i think something is wrong. Try to reseat your graphic card into pcie slot. Also if it doesnt help go to Bios and change source in there.
    http://www.tomshardware.co.uk/answers/id-2385951/disable-onboard-graphics-asus-maximus-vii-hero.html
    Reply to Makentox
Ask a new question Answer

Read More

Drivers