Cant find my fan speed for my Corsair H80 V2 fans after switching motherboards

I recently switched my motherboard from a z170 chipset to a z270 chipset, After i switched motherboards i wanted to test things out to make sure they were ok. everything was fine, but for some reason i could not control my fans to my liquid cooling kit in corsair link. I have tried switching if from CPU fan to Pump Fan. To be a little more clear on what i switched, i switched from a GIgabyte Gaming 5 Z-170 to a MSI Z-270 Gaming M3, And of course i switched my processor from a I7 67k to a I7 77k. ive tried re-downloading Corsiar Link 3 times and i cannot see to get the problem fixed. Any help would be GREATLY appreciated.

My Specs.
MSI GTX 1080 8gb
MSI z-270 gaming M3
I7-7700k
16gb Platium Corsair ram
H80i V2
a few fans from my case
4 tb Western Digital HDD
250 Gb Samsung SSD
Reply to Ch1ck3nubbl37
1 answer Last reply
More about find fan speed corsair h80 fans switching motherboards
  1. The first thing is to make sure you are using the Y cable they give you, second is to make sure that the Corsair link cable is connected to the water block, and lastly, check to see if you have connected the Corsair link cable to a USB connector on the bottom of the mobo.
    Reply to Tmas_
Ask a new question Answer

Read More

Chipsets Motherboards Fan Speed