Solved

Asus Maximus Hero IX Blu-Ray and Sata Issues

Greetings fellow builders.
I am fairly new to building PC and last night I finally grew a pair and build my PC myself for the first time. There were moments I didn't knew what I was doing. Took me about 6 hours to put it all together. It all worked in the end. Lots of youtube videos!!

Here are the details ( I pulled out some of the parts from my older PC )

Processor: Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz (8 CPUs), ~4.2GHz

Motherboard: Asus Maximus Hero IX

Ram: Vengence 32Gigs.

Video Card : GTX 980 Strix

PSU - Cooler Master 850

OS: Windows 10 Home edition

HDD: WD Cavier Black 1TB, WD Regular 500GB ( Pulled out these two drives from my older system)

SSD: 950 PRO NVMe M.2 SSD (My Windows are installed on this SSD)

Cd Drive: LG Blu-Ray Drive.


MY PROBLEM:

My BlueRay Drive (Lets call it BD) wont get detected in the windows. It wasn't just showing up. I thought it might be the sata Cable. So i swap the cable with a new one... Still nothing. it didn't work.

I rebooted my PC went to BIOS and the BD wasn't showing up in there either. I went to boot menu and tried to see if it was available in the boot options.. No luck :(

I later swapped my Sata cable for Blu-Ray from SLot 6 to Slot4 and it works right away and Windows detected my Blu-ray.

I also tried to plug in my HDD ( Cavier Black ) in to slot 5 ( Sata) It didn't detect my HDD either.

Now before you read further. Let me tell you.. I have a very bad knowledge about sata connectors. I dont know what Raid is and what IDE is.

Here are the photos of my connections on the boards
1.This layout DID NOT work
http://i.imgur.com/aBZRUqO.jpg

2. This layout worked
http://i.imgur.com/wiU4kWD.jpg

My question is
A - Why is this happening?
B - Should I be worried that my Sata port 5 and 6 are bad? and I should get my board replaced?

I read some posts and they suggested that optical drives should be connected to slot 5. But this isnt working for me. I am scared that my mother boards if bad and the fact that my HDD was also not detected in slot 5 makes me worried even more.

Please advice what I should do or if there is a way to detect a faulty Sata port.

Kind Regards

I am open to Discussion. If you need anymore information or photos. I'll be more than happy to share. Just ask :)
Reply to rdhalla
2 answers Last reply Best Answer
More about asus maximus hero blu ray sata issues
  1. Best answer
    Straight from mobo specification:
    "*2 When the M.2_1 Socket 3 is operating in SATA mode, SATA port 1 will be disabled.
    *3 When the M.2_2 Socket 3 is operating in PCIEX4 mode, SATA port 5. 6 will be disabled."

    Does it fully answers your question or do I have to explain more?
    Reply to DRagor
  2. DRagor said:
    Straight from mobo specification:
    "*2 When the M.2_1 Socket 3 is operating in SATA mode, SATA port 1 will be disabled.
    *3 When the M.2_2 Socket 3 is operating in PCIEX4 mode, SATA port 5. 6 will be disabled."

    Does it fully answers your question or do I have to explain more?


    Thank you so much!!! That's explains.
    Reply to rdhalla
Ask a new question Answer