Solved

Can only see EFI files from old SSD

I had a Lenovo yoga I purchased about 5 years ago that took a header and would no longer power on, or show any sort of life. There are several very important files that I need to get off so I bought a mSATA to SATA adapter, which I am using with SATA to USB. I have also tried using a desktop and connecting the sata and power cables with same result.

Original SSD I am trying to recover files from. ( Link )

My issue is, the device is not discovered from 6 computers, I can see it listed in diskpart but its status is no media and size is 0. I have one HP laptop that will assign a drive letter than I can see from file explorer. It claims to only be 256mb ish, even thought its a 128gb ssd. When I use recuva from piriform on the Z, all I can see is mostly windows boot files, and a few HP bios files which doesn't make a lot of since, seeings how it came out of a lenovo.

Anyone have any idea what I can do to recover the files, or at least check the integrity of the ssd?

I could try installing into a mini pci e slot on a different desktop?

Thanks for the help.
Reply to npk21
1 answer Last reply Best Answer
More about efi files ssd
  1. Best answer
    Try a different mSATA to SATA adapter. If that does not work, the drive may just be damaged.
    Reply to hang-the-9
Ask a new question Answer

Read More

Data Recovery SSD Lenovo SATA