Solved

Black screen and poor performance after installing Creators Update

Hi guys,
after installing W10 Creators Update I have following issues:
- randomly the cursor slows down in Windows and the screen turns black after some time
- after some time when I play games (ie BF1), the fps drops from 100fps to like 3-5 and the title stops responding, if I wont kill the game in Task Manager in time, black screen will occur as well

The temps are OK, PSU is more than enough - 1000W. The issue was not happening before creators update. I rolled back to like 3 different versions of previous nVidia drivers but the same issue occurs.

I have 2x GTX 1080 FE and Acer XB270HU G-Sync screen.

Im not a nube user, buidling PCs for myself and friends for over 20 years but with this one I have tried everything

I guess I need to wait until Mircosoft/nVIdia will patch it? Any ideas?

Full specs: CPU: i7 4930k, 6 Cores, OC @ 4,5Ghz (1.275V)
GPU: SLI 2x nVidia GTX 1080 FE at 1975Mhz
MOBO: ASUS Rampage IV Black Edition X79
RAM: 64GB G.SKILL RipjawsZ @ 1600Mhz CL10, Quad Channel (1 QVL kit)
MONITOR: Acer Predator XB270HU 27", 2560x1440, 144hz, G-Sync
HDD: Kingston HyperX 240GB SSD, CRUCIAL M550 1TB SSD
OS: WINDOWS 10 PRO 64-Bit
PSU: CORSAIR RM1000x - 1000W
CASE: NZXT H630 Black Silent
AUDIO: Sound Blaster ZxR
Reply to littlespy1980
1 answer Last reply Best Answer
More about black screen poor performance installing creators update
  1. Best answer
    littlespy1980 said:
    Hi guys,
    after installing W10 Creators Update I have following issues:
    - randomly the cursor slows down in Windows and the screen turns black after some time
    - after some time when I play games (ie BF1), the fps drops from 100fps to like 3-5 and the title stops responding, if I wont kill the game in Task Manager in time, black screen will occur as well

    The temps are OK, PSU is more than enough - 1000W. The issue was not happening before creators update. I rolled back to like 3 different versions of previous nVidia drivers but the same issue occurs.

    I have 2x GTX 1080 FE and Acer XB270HU G-Sync screen.

    Im not a nube user, buidling PCs for myself and friends for over 20 years but with this one I have tried everything

    I guess I need to wait until Mircosoft/nVIdia will patch it? Any ideas?

    Full specs: CPU: i7 4930k, 6 Cores, OC @ 4,5Ghz (1.275V)
    GPU: SLI 2x nVidia GTX 1080 FE at 1975Mhz
    MOBO: ASUS Rampage IV Black Edition X79
    RAM: 64GB G.SKILL RipjawsZ @ 1600Mhz CL10, Quad Channel (1 QVL kit)
    MONITOR: Acer Predator XB270HU 27", 2560x1440, 144hz, G-Sync
    HDD: Kingston HyperX 240GB SSD, CRUCIAL M550 1TB SSD
    OS: WINDOWS 10 PRO 64-Bit
    PSU: CORSAIR RM1000x - 1000W
    CASE: NZXT H630 Black Silent
    AUDIO: Sound Blaster ZxR


    Ha! I have fixed it. I have changed Monitor refresh rate value in nVidia Control Panel 3d settings from "Maximum monitor refresh rate" to "Controled by application". After reinstalling the drivers/OS update this value must have changed somehowe causing conflicts. SO far 1h in BF1 and in the OS and no issues. Still using 381.89 and W10 1607.
    Reply to littlespy1980
Ask a new question Answer

Read More

windows 10 Performance Windows Update Video Driver Battlefield