Solved

Asus prime Z270-A doesn't boot, CPU and DRAM lights blinks. might be stuck on MEMOK! loop

Hi,

I just build myfirst PC with the following spec:
Asus prime Z270-A
i7-7700
Corsair vengence DDR4 2X8GB CMU16GX4M2C3200C16
msi GeForce GTX 1070 (used in my last pc and works great)

when I turn on the computer, the CPU LED starts to blink following with longer blink on the DRAM LED.
My bios version is 0604 and I tried different memory configurations and pressing the MemOK!.
Also I changed the EZ_XMP configuration.

video: https://youtu.be/0SCWB3LKubQ

some pictures of the system: http://imgur.com/a/TD1yA


-----edit---
according to ASUS, it looks like my computer is stuck on MEMOK! loop. the DRAM LED blinks and not stays on.
https://www.asus.com/US/support/FAQ/1012266
-------------

Does anyone knows how to solve that?
Reply to kazi1982
4 answers Last reply Best Answer
More about asus prime z270 boot cpu dram lights blinks
  1. i7-7700 uses DDR4-2400MHz on Intel 200 Series motherboard. It has a locked multiplier so is not easily OC.

    Corsair Vengeance DDR4 2X8GB CMU16GX4M2C3200C16
    SPD Speed is 2133MHz which is what it runs at on [Auto].
    Reply to Calvin7
  2. According to intel ark the supported memory is:
    DDR4-2133/2400, DDR3L-1333/1600 @ 1.35V

    So I've replaced the memory to Kingston HyperX FURY 2x8GB DDR4 244MHz (HX424C15FC2K2/16) which should work. Still I get the same result :(
    "No POST", "system won't boot", and "no video output" troubleshooting checklist
    "No POST", "system won't boot", and "no video output" troubleshooting checklistThis checklist is a compilation of troubleshooting ideas from many forum members. It's very important to actually perform every step in the checklist if you want to effectively... Read More
    Reply to kazi1982
  3. After doing the checklist I tried again to boot the computer without memory at all - all slots were empty and I got the same result.
    I thought that I haven't put my memory well so I reinstalled it to make sure it's installed properly, and still nothing changed.
    I also tired again with one memory stick and resetting the bios but it didn't changed the outcome. As part of the troubleshooting I did before, I took out the graphic card, although it worked on a different computer.
    Reply to kazi1982
  4. Best answer
    After checking everything twice I unplug all connections and It works. By connecting each connection and check it I found out that one of the case connection (the reset button) was connected wrong ( minus to plus ).
    fixing that solved the problam
    Reply to kazi1982
Ask a new question Answer

Read More

Asus Boot Failure Intel i7 Corsair Motherboards