Solved

Asus PRIME z270-a with bios 0505 POST with i7-6700k?

I've got a Asus prime z270-a out of the box with bios I think 0505 as written on the label.
I also have an i7 6700k installed and then had a solid orange light for the ram showed up (corsair ddr4 8gb 2400mhz) on the mobo, CPU blinked red then off (that's good I think) the new one comes tomorrow. Will I still have issues?

Having to swap out for a Kaby lake will be very hard for me, just to update the bios.
Has had success with a similar setup out of the box?

Thank you for reading and any help you may provide!
Reply to mauther
8 answers Last reply Best Answer
More about asus prime z270 bios 0505 post 6700k
  1. mauther said:
    I've got a Asus prime z270-a out of the box with bios I think 0505 as written on the label.
    I also have an i7 6700k installed and then had a solid orange light for the ram showed up (corsair ddr4 8gb 2400mhz) on the mobo, CPU blinked red then off (that's good I think) the new one comes tomorrow. Will I still have issues?

    Having to swap out for a Kaby lake will be very hard for me, just to update the bios.
    Has had success with a similar setup out of the box?

    Thank you for reading and any help you may provide!


    Have you tried different RAM slots? As for the bios, I do not see 0505 listed on their website. Every CPU validated is for 0604. Possible you got a really old batch? You'd think it would work out of the box as it's a Z270.
    Reply to krzyimprt
  2. krzyimprt said:
    mauther said:
    I've got a Asus prime z270-a out of the box with bios I think 0505 as written on the label.
    I also have an i7 6700k installed and then had a solid orange light for the ram showed up (corsair ddr4 8gb 2400mhz) on the mobo, CPU blinked red then off (that's good I think) the new one comes tomorrow. Will I still have issues?

    Having to swap out for a Kaby lake will be very hard for me, just to update the bios.
    Has had success with a similar setup out of the box?

    Thank you for reading and any help you may provide!


    Have you tried different RAM slots? As for the bios, I do not see 0505 listed on their website. Every CPU validated is for 0604. Possible you got a really old batch? You'd think it would work out of the box as it's a Z270.

    Thanks! I tried the A2 and the rest of them. I'm hoping the new ram will solve the problem tomorrow.

    I should add new psu also (evo 600)

    I'll report back for others to see also, fingers crossed!
    Reply to mauther
  3. mauther said:
    krzyimprt said:
    mauther said:
    I've got a Asus prime z270-a out of the box with bios I think 0505 as written on the label.
    I also have an i7 6700k installed and then had a solid orange light for the ram showed up (corsair ddr4 8gb 2400mhz) on the mobo, CPU blinked red then off (that's good I think) the new one comes tomorrow. Will I still have issues?

    Having to swap out for a Kaby lake will be very hard for me, just to update the bios.
    Has had success with a similar setup out of the box?

    Thank you for reading and any help you may provide!


    Have you tried different RAM slots? As for the bios, I do not see 0505 listed on their website. Every CPU validated is for 0604. Possible you got a really old batch? You'd think it would work out of the box as it's a Z270.

    Thanks! I tried the A2 and the rest of them. I'm hoping the new ram will solve the problem tomorrow.

    I should add new psu also (evo 600)

    I'll report back for others to see also, fingers crossed!


    If you have a pair of RAM 2x4GB try a single stick at a time in different slots. One could be defective causing it not to post.
    Reply to krzyimprt
  4. If you have a pair of RAM 2x4GB try a single stick at a time in different slots. One could be defective causing it not to post.

    Alas, it was a single 8gb stick. The vendor has been great though, so tomorrow I'll see what happens, even if it gets past that I'm still not sure if will work but the CPU light is not on which is a good sign.
    Reply to mauther
  5. I`m happy to say as I write this from the com that all is working after the replacement RAM (currently in B2 btw). This will POST with 0505 bios with a I7-6700K. Thank the gods.
    Reply to mauther
  6. mauther said:
    I`m happy to say as I write this from the com that all is working after the replacement RAM (currently in B2 btw). This will POST with 0505 bios with a I7-6700K. Thank the gods.


    i have the same issue..
    you mind telling me what the new ram was ?
    Reply to TheZo123
  7. TheZo123 said:
    mauther said:
    I`m happy to say as I write this from the com that all is working after the replacement RAM (currently in B2 btw). This will POST with 0505 bios with a I7-6700K. Thank the gods.


    i have the same issue..
    you mind telling me what the new ram was ?


    The RAM is Crucial 8GB Single DDR4 2400 MT/s (PC4-192000) DIMM 288-Pin Memory - CT8G4DFD824A.
    https://www.amazon.co.uk/gp/product/B019FRED60/ref=oh_aui_detailpage_o06_s00?ie=UTF8&psc=1

    Hope this helps.
    Reply to mauther
  8. Best answer
    mauther said:
    TheZo123 said:
    mauther said:
    I`m happy to say as I write this from the com that all is working after the replacement RAM (currently in B2 btw). This will POST with 0505 bios with a I7-6700K. Thank the gods.


    i have the same issue..
    you mind telling me what the new ram was ?


    The RAM is Crucial 8GB Single DDR4 2400 MT/s (PC4-192000) DIMM 288-Pin Memory - CT8G4DFD824A.
    https://www.amazon.co.uk/gp/product/B019FRED60/ref=oh_aui_detailpage_o06_s00?ie=UTF8&psc=1

    Hope this helps.


    yes, thanks a lot mate :)
    computer issues are a b****
    Reply to TheZo123
Ask a new question Answer

Read More

Asus BIOS RAM Intel i7 DDR4