Solved

Monitor No Signal, GPU Fan at Max speed

Whenever I turn on my computer, the screen go asleep and say VGA no signal. Also my GPU's fan goes a max speed.

I've tried taken out my ram sticks, CMOS battery, cleaning my motherboard and GPU for dust, making sure the CPU cooling unit is secure. With or without my GPU in, my motherboard doesn't beep at all.

Computer Specs:
Motherboard: Gigabyte 970A-DS3P AMD 970
GPU: NIVIDA GTX 660 2 GB
Power Supply: 750 Watts- Thermaltake SMART series
4 answers Last reply Best Answer
More about monitor signal gpu fan max speed
  1. I guess that's not new build? Any recent hardware changes? How many ram sticks you have?
  2. DRagor said:
    I guess that's not new build? Any recent hardware changes? How many ram sticks you have?


    No I've been using it for a couple of years now, has never given me this much trouble. I have 2.
  3. Okay, first step: disconnect everything except CPU, GPU and PSU from motherboard, also remove all ram sticks, keyboard, mouse, everything. Try to boot - you should get beep code error at this point.
  4. Best answer
    Take out the card and inspect it, maybe it burned out.
    Or maybe the vga 6 pin power supply cables burned out.
    Try using a different GPU if you have one and see if it boots.
    If you have two of them switch them and just one one, see if it still has issues. If it has issues in one slot, move it to the other. Troubleshoot your GPU first.
    Next thing I would think is that it's just your PSU having issues powering up. I mean, two 660's take a lot of power (they both require independent 2x6 pin connections), so try just one. Or if you have a GPU that doesn't require a pin connection try that one instead.

    I think it's your PSU tbh. If you have another PSU in the household try it.
Ask a new question

Read More

GPUs Motherboards