Boot Device LED on (red) - PC will get to log screen (Asus/bios), but won't complete boot up

I have an older PC and it's all I have until I can build a new rig. Today it booted to the ASUS log screen, but could not get past this screen. My keyboard & mouse are unresponsive, no matter which USB outlet I plug them into. So I cannot get into the BIOS.

I have unplugged the SSD, on both ends, same issue. I have done a hard reset, same issue. I have unplugged each RAM card, same issue.

I can usually solve these issues by reading the forums here or on YT, but alas, I'm at a loss, hence why I am here. Your help is much appreciated.

Specs:

Mobo: Asus P8Z77-V
RAM: 2x4GB Corsair Dominator
CPU: Intel i5-3570K 3.4ghz
GPU: GTX 570
PSU: Corsair HX750
SSD: 120GB Corsair Neutron (OS)
HDD: Seagate 1TB (Storage)
9 answers Last reply
More about boot device led red log screen asus bios complete boot
  1. Have you tried clearing the CMOS (unplug the power cord and remove the CMOS battery for a minute)?
  2. error codes/beep codes???
  3. alexoiu said:
    Have you tried clearing the CMOS (unplug the power cord and remove the CMOS battery for a minute)?


    Yes, I have. Same issue.
  4. What components are currently connected to the motherboard?
  5. mrmike_49 said:
    error codes/beep codes???


    Neither. The PC turns on, the fans spin up, the mobo goes through all the LEDs, but stalls at Boot Device. The keyboard does not register with any USBs so I cannot push F2 or DEL to enter BIOS, but the screen loads.
  6. alexoiu said:
    What components are currently connected to the motherboard?


    Currently, everything.
  7. Try leaving only CPU, CPU cooler and single RAM installed.
  8. alexoiu said:
    Try leaving only CPU, CPU cooler and single RAM installed.


    Tried it. Same issue.
  9. You could try replacing the BIOS chip with a new one from ebay, but I'm not sure that it would solve the issue.
Ask a new question

Read More

Asus Boot LED Monitor