Solved

M2 SSD With OS Installed Won't Boot (0xc000021a error)

So recently I got a new Lenovo Y520 gaming laptop with 128GB M.2 SSD (Samsung PM961) and a regular 1TB HDD. The OS (Windows 10) was factory installed on the M2 SSD, unfortunately, after deleting some useless crap folders from uninstalled software, the laptop screen went black and froze, not responding to anything whatsoever.

After that, I held down the power button to completely turn off the PC, now every time I turn it on, I get this Windows error 0xc000021a, telling me that the PC didnt start correctly and needs to reboot. It then goes into auto repair mode but nothing helps. I've tried all the possible options of repairing the PC with a Windows 10 USB stick. Nothing helps.

I then decided to install Windows 10 on the HDD, since it wont install on the M2 SSD, as their is apparrently only 128 MB of space on it when you install Windows 10 from the USB. Installing on the HDD works flawlessly, but still, I want to factory reset/restore/recover the M2 SSD. After booting into Windows 10 from the HDD, I can see the M2 SSD in the state I left it in, when I go into "This Computer" with all the folders and stuff in it.

What should I try now guys?
16 answers Last reply Best Answer
More about ssd installed boot 0xc000021a error
  1. Bug Check 0xC000021A: STATUS_SYSTEM_PROCESS_TERMINATED
    The STATUS_SYSTEM_PROCESS_TERMINATED bug check has a value of 0xC000021A. This means that an error has occurred in a crucial user-mode subsystem.

    when you tried to use the m.2, did you do a custom install or just let it do a normal one? Its likely the 128mb left is just what wasn't already partitioned.

    I would copy anything off M.2 you want to rescue now and then remove hdd from laptop and then follow this: https://www.tenforums.com/tutorials/1950-clean-install-windows-10-a.html
  2. The M.2 was the drive the OS was installed on from the factory with all the bloatware and so on.

    Do you mean a custom install from Windows 10 installation? If so yes.

    If it's possible I do want to keep default Lenovo recovery with all the bloatware in case I decide to sell it down the line.
  3. I would dettach hdd if you can and then boot from installer
    on 2nd screen after languages, choose repair this pc, not install
    choose troubleshoot
    choose reset this PC
    choose factory reset
    PC will restart and reinstall itself like it was before you got it.
  4. @Hamzoro, watch your language. :non:
  5. So I detached the HDD and a new sentence "Repairing Diskfail, this can take more than an hour" joins the reboot mix along with the other two. Plugged in the Windows 10 USB Stick and tried what you said, but it gives me an error when I try restoring the PC. Actually it gives me an error everytime I try all the offered options by the blue screen (Windows boot manager?).

    Detached the battery and plugged it in again, detached the M2 SSD and plugged it back in again, none of this worked.

    Man I've never encountered such a Deleted Windows error ever! I suppose the last thing to do is to secure erase the M2 SSD and used it as a storage drive for games and so on. The question is how do I do that?
  6. How recently did you get the Laptop as I would consider taking it to a lenova repair centre and get them to fix it, if its fairly new. It would be under warranty.

    Can't see disk fail, found disk error - its chkdsk trying to fix file errors, so it says that and then reboots? SSD are fast but it should take some time to fix files before it restarts
  7. Yea, I meant disk error, indeed it just keeps saying that and then reboots over and over. Is it supposed to do that? Besides, isn't is possible to do chkdsk from the HDD in cmd? I'll try searching the web for more solutions and we'll see what happens.

    One more thing, it looks like after i dettached and reattached the M2 SSD it wont give me permission to enter it from "Computer" when booting Windows from the HDD. Looks like it's locked now haha, this keeps getting better and better.

    Update: After going into properties and security of the M2 SSD disk, I managed to change ownership rights and now it opens again with all the files in it.
  8. Does m.2 show in disk management? (right click This PC, choose manage from menu. in next screen, in left column choose disk management and expand the centre column so you can see it all. Is it there? Is it right size?)

    when you run chkdsk from CMD it will insist on running at start up before win 10 is running (unless you run it off the installer). Its possible that the PC is trying to restart to run chkdsk and gets stuck in that boot loop instead.

    I wonder if cleaning M.2 will get rid of all these messages. << this wipes drive btw.
    I would unplug hdd or be careful which drive you choose doing the next bit:
    Press Shift F10 on the installation screen, this will open cmd
    type diskpart and press enter
    type list disk and press enter
    this shows all drives available, DVD/USB and hdd, make note of hdd number
    type Select disk X - where X is the number of the hdd you want to install to, change X to that number and press enter
    once the drive you want to install on is chosen, type Clean << this wipes drive so be careful you chose right one
  9. I now did as you said and the M.2 SSD has been wiped and is clean now with nothing on it. However, now it doesnt show up in BIOS and Boot Manager, only when you go into the Windows 10 installation does it show with it's 128MB where Windows cant be installed on.

    Is there even a way to install Windows on this M2 SSD? And how do I get it to show up in the BIOS and Boot Manager? The M2 does show up when booting into the HDD and clicking on "Computer" and also shows up in Disk Management, but that's it.
  10. 128mb in installer, 128gb in disk management. almost like they two different drives... can you take a screen shot of disk management and upload it to an image sharing site and share link here?

    if M.2 is seen in disk management, the bios must see it somewhere as windows gets into from bios. Its possible M.2 appears as storage or something in bios, not in same area as hdd since it isn't sata, its attached to motherboard.

    if this was a really old laptop they used to come with 128mb ssd that worked as cache drives for the hdd but yours is brand new and I seen the web site that mentions the m.2

    You positive its got 2 drives?
    Quote:
    Storage -
    128 GB / 256 GB PCIe SSD or
    1 TB / 2 TB SATA HDD


    http://shop.lenovo.com/us/en/laptops/ideapad/legion-y-series/y520/

    did you order an extra?
  11. Yes, the 128GB m2 SSD was the one used as the OS drive from the factory, the 1TB HDD is just for additional storage. I'll post a picture when I get home (couple of hours)
  12. .....
  13. no rush, I have to go soon so I look when i return (In about 8 hours)
  14. Ok, the following picture is from "Computer", no problems here.
    http://i38.photobucket.com/albums/e124/Hamzoro/IMG_0775_zpsyqlwphra.jpg

    This is from Disk Management, cant see any problems here either.
    http://i38.photobucket.com/albums/e124/Hamzoro/IMG_0776_zpsj3mtgfaa.jpg

    I dont know how, but it suddenly showed up in BIOS again, I did install a game on the drive, perhaps that's why?
    http://i38.photobucket.com/albums/e124/Hamzoro/IMG_0779_zps3osmihaa.jpg

    Boot Manager, no M2 showing here
    http://i38.photobucket.com/albums/e124/Hamzoro/IMG_0780_zpspqy6o7wi.jpg

    Lastly we have the Windows 10 installation with the M2 and it's mighty 128MB
    http://i38.photobucket.com/albums/e124/Hamzoro/IMG_0781_zpsqctgxawp.jpg

    Sorry for the crappy quality though
  15. Best answer
    bottom picture isn't seeing ssd at all, its all the hdd. Easy to tell, if you had 2 drives showing you would have disc 0 and Disc 1, you have 5 partitions on the 1tb HDD showing there.

    1 mystery solved.

    This sounds familiar:
    Quote:
    So I bought a Legion Y520, and added a Samsung SM961 M.2 SSD in addition to a 1TB HDD that I got with the laptop. And now I want to install Windows 10 to the SSD. However, Windows setup does not detect the SSD, only the HDD. BIOS however, when in UEFI mode, detects the SSD normally.

    What am I missing? How do I successfully install Windows 10 on the SSD?

    EDIT: Solved the problem. In BIOS, under Configuration, I had to change "SATA Controller Mode" to "AHCI".


    https://forums.lenovo.com/t5/Gaming-Laptops/EDIT-Solved-Y520-Installing-Windows-10-on-M-2-SSD/td-p/3612700
  16. Hmm, I see, after changing to AHCI the M2 does indeed show up in the Windows 10 installation.
    http://i38.photobucket.com/albums/e124/Hamzoro/IMG_0782_zpszsnipdrm.jpg

    So, I went into Lenovos website and inquired for a Lenovo Y520 Recovery USB with all bloatware on as it comes from the factory. They gave me a PDF document describing how I can do it myself with Lenovo USB Recovery Creator software. Downloaded it, put it on the Windows 10 USB stick and installed this factory Windows 10 with bloatware on the M2 SSD. Finally, back to square one :D

    Thanks man, you really enlightened me through this process and taught me some new stuff. I really do appreciate it!
Ask a new question

Read More

Reboot Loop USB Stick 0xc000021a Hard Drives Samsung M2 SSD Boot Error Message Lenovo windows 10 SSD