Gigabyte Windforce RX 470 Smart Power LED Indicator Flashing

I've tried making sure the PCI-E cables were in the GPU as much as it can go in and bumping the power limit up for the Graphics Card, but the light keeps flashing every few minutes while I'm not playing games on it. The light flashes once then goes away after a second.

Here's my PC specs: https://pcpartpicker.com/list/LtLvhq
Here's a video I made to give yall an idea of what my problem is.

https://youtu.be/dapgcoFUCgw
3 answers Last reply
More about gigabyte windforce 470 smart power led indicator flashing
  1. on the mb make sure the 4/8 pin cpu power plug is in all the way. most of the gpu power will come from this plug. make sure the mb has the newest bios to rule out a bug. use hardware info and the voltage readings in the bios. make sure the 12v rail is over 12v if it reading under 12v rma the power supply.
  2. smorizio said:
    on the mb make sure the 4/8 pin cpu power plug is in all the way. most of the gpu power will come from this plug. make sure the mb has the newest bios to rule out a bug. use hardware info and the voltage readings in the bios. make sure the 12v rail is over 12v if it reading under 12v rma the power supply.

    I checked the 12V rail in the BIOS and it reads as 12.384V. So maybe I should try to update the BIOS. I already tried reinstalling the GPU drivers and it came back again.
  3. I updated my BIOS and made sure my CPU was in tight and I still see the LED Indicator flashing once and disappearing. Should I just get another GPU, RMA it or something else?
Ask a new question

Read More

LED Monitor Power