Solved

Installed new RAM computer won't boot/stuck in a restart loop

Motherboard: Gigabyte GA-P67A-D3-B3 rev1.0 (BIOS v.F3)

So I bought these RAM sticks: https://www.newegg.com/Product/Product.aspx?Item=N82E16820226095

At first I tried to run with both old (also 2x4GB DDR3-1333) and new ones, it failed as it kept restarting after 3 seconds each time.
Then I tried with just the new ones, same thing.
I tried each one separatelly, same thing.
Tried removing the CMOS battery, still the same.
If I put just the old sticks it works fine, so did I make a mistake buying these or are they bad?
1 answer Last reply Best Answer
More about installed ram computer boot stuck restart loop
  1. Best answer
    I am sure that RAM had the compatibility problem with the old intel MB, because you had the old lga1155 MB, they are picky for the RAM, when you buy the RAM, you are better to check it out to see the RAM are compatible with your MB or not, that is for old intel MB only, like the Mushkin, if you can't find the info, don't buy it.

    You are better to return they, and buy the RAM like G.SKILL AEGIS 8GB https://www.newegg.com/Product/Product.aspx?Item=N82E16820231733&ignorebbr=1 or G.SKILL Ripjaws X Series 8GB https://www.newegg.com/Product/Product.aspx?Item=N82E16820231689&ignorebbr=1 you can see they are compatible with Intel LGA1155 platforms under the specifications. And keep in mind the RAM (2133mhz) will run at 1333mhz if you don't oc.
    Also here is from gskill site, check the QVL, and you will see your MB is in that list. http://www.gskill.com/en/product/f3-2133c9d-8gxl
Ask a new question

Read More

Computers RAM Boot Gigabyte BIOS Motherboards