Solved

HELP! New PC Build Issues

I am in the middle of building my pc and everything is installed except GPU. When I try to turn on PC, fans do not spin, and after a few seconds I hear a clicking noise and the PC turns off. Help?
7 answers Last reply Best Answer
More about build issues
  1. Try taking the board outside the case and testing it there.
  2. alexoiu said:
    Try taking the board outside the case and testing it there.


    I already have everything plugged into motherboard. cords are not long enought for it to be taken outside of case. Also, clicking noise seems to be coming from PSU. It makes the same sound when you hit the test button.
  3. It might be a short. Have you installed the standoffs in the correct positions?
  4. alexoiu said:
    It might be a short. Have you installed the standoffs in the correct positions?


    The standoff came preinstalled. might have done the screws on the motherboard too tight tho. Im guessing ur talking about the motherboard. And do you have any clues why the fans wont run?
  5. Even if preinstalled, you have to make sure that each one does match a screw hole on the motherboard.
  6. alexoiu said:
    Even if preinstalled, you have to make sure that each one does match a screw hole on the motherboard.


    um i think i know why power supply is shutting down. Forgot to install cpu cooler. CPU was insanely hot. Do you think that may be why? and also do you have an idea about why the fans wont run? Or are they connected to the PSU issue
  7. Best answer
Ask a new question

Read More

GPUs Build