New psu, new motherboard, new CPU... still no signal to monitor or error beeps during post.

OS: Windows 10 CPU: AMD FX 6300 Motherboard: MSI 970A-G43plus Memory: ADATA DDR3 1600 (11) 4gx8 (dual channel) PSU: EVGA Supernova NEX 750 watt GPU: MSI GTX960 gaming 4g HDD: Toshiba

So this is a machine that friend bought from iBUYPOWER. About a week ago while using it, it just lost power completely and would not power back up. The psu at that time was a 600 watt, I don't remember the brand, but it was bronze rated.

My first thought was to replace the psu, so we did and the pc would power up, but no signal would display on the monitor and there were no error beeps during post (this board doesn't have post error lights).

I then put his gpu in my machine and it worked, I put my working gpu in his machine and we got the same results, no display and no error beeps.
We took out each component one at a time, down to only the cpu and cpu cooler, each time testing for post error beeps, we received none.
We tried to reset the cmos, both by jumping and removing the battery, again the same results. We then replaced the motherboard, no display and no error beeps after removing each component as before.

My last guess was that it was the cpu, which we replaced today, and we are still receiving the same result, no display, no error beeps during post. Again, I tested it one component at a time.
I'm fresh out of ideas and we're both at our wit's end, please help. Thanks in advance.
5 answers Last reply
More about psu motherboard cpu signal monitor error beeps post
  1. Did you test the memory?
  2. Could be anything really, try testing ram like the dude above me said, also maybe certain things aren't plugged into the right ports or maybe the monitor is the issue or just replace literally everything.
  3. Didn't have any DDR3 memory to test in it. Working on finding some. But shouldn't I get an error beep if it is the memory?
  4. Monitor works with another machine and I've tried it on two different monitors. Tried different ram also, still same results.
  5. That's really weird, how can you replace almost everything and it still doesn't work? crazy. Just have to try different combos I guess.
Ask a new question

Read More

CPUs Motherboards