Solved

MSI laptop gets to the boot screen and doesn't load, shuts down after 15 seconds.

I have a MSI laptop and yesterday after going to the movies I tried starting up my laptop again and it got the the boot screen, where i see the logo of MSI but it doesn't load. Fans start and maybe 15 seconds later it all powers down. About 1 or 2 weeks ago I installed windows 10 (Not sure if important but you never know) Also I looked up how to fix it and tried removing the battery and turn it on only with charging cable. Didn't work, however when i put the battery back in place it booted up normally and then today same issue acured a left my laptop on to go eat dinner nothing was running no game or video so it would have gone to sleep after 5 min. Now I don't know what to do. I am no computer genius so any help is appreciated.

Thanks in advance.
3 answers Last reply Best Answer
More about msi laptop boot screen load shuts seconds
  1. Check the battery's connection to the laptop itself. If taking the battery out and putting it back in fixed it, then it could just be that the connection was bad and you managed to put it back in in a way that gave it enough connection. Try cleaning any dust out of it. The other place it could be failing is the actual battery connection to the laptops motherboard. Sometimes that could come loose and then (again) you loose electrical connection. If this is the issue and you're not much of a computer guy, you probably will want to take it to geek squad or something because that would involve re-soldering the connections and isn't something that's easy/fun to work with.
  2. Unboundstorm said:
    Check the battery's connection to the laptop itself. If taking the battery out and putting it back in fixed it, then it could just be that the connection was bad and you managed to put it back in in a way that gave it enough connection. Try cleaning any dust out of it. The other place it could be failing is the actual battery connection to the laptops motherboard. Sometimes that could come loose and then (again) you loose electrical connection. If this is the issue and you're not much of a computer guy, you probably will want to take it to geek squad or something because that would involve re-soldering the connections and isn't something that's easy/fun to work with.



    Thanks but after posting this i went to look deeper then jsut googling my problem. Decided to visit the main msi support tech page

    https://service.msicomputer.com/msi_user/support/TechFAQdetail.aspx?formid=3524

    This worked for without doing anything ideas on how to prevent it from happening again?

    UPDATE: Windows just told me to restart to fix driver errors so i am doing that now will keep updating incase it happens to anyone else
  3. Best answer
    MSIHELP123 said:
    Thanks but after posting this i went to look deeper then jsut googling my problem. Decided to visit the main msi support tech page

    https://service.msicomputer.com/msi_user/support/TechFAQdetail.aspx?formid=3524

    This worked for without doing anything ideas on how to prevent it from happening again?



    Unfortunately if MSI is saying it's an issue with Win10, there's nothing you can do until Microsoft fixes the issue themselves. I'm having some issues with Win10 too but I just have to hope that Microsoft figures them out. Until they fix the problems, keep doing the disc check when it fails to start.
Ask a new question

Read More

Gaming MSI-Microstar Help Battery Reboot Windows10 Laptops Pc Shutdown