Solved

AMD Radeon HD 6850 not working after uninstalling drivers and reinstalling them

Some information:
-CPU Z recognizes my graphics card being plugged in, but it shows no clock information
-I can only use my monitors vga graphics card (?)
-No graphics card to be found in device manager
-All cables are properly plugged in
-I uninstalled all drivers using amd's own software
-I tried to reinstall drivers (which by itself worked) but the card is not being recognised
5 answers Last reply Best Answer
More about amd radeon 6850 working uninstalling drivers reinstalling
  1. Had the same problem the only way I got it fixxed was by resetting my hdd
  2. Ironic_2 said:
    Had the same problem the only way I got it fixxed was by resetting my hdd


    how do i do this? what consequences would i have to face?
    excuse me though, im a pc newbie, willing to learn more.
  3. Lawsker said:
    Ironic_2 said:
    Had the same problem the only way I got it fixxed was by resetting my hdd


    how do i do this? what consequences would i have to face?
    excuse me though, im a pc newbie, willing to learn more.


    It will pretty much delete all of your files except windows
  4. Ironic_2 said:
    Lawsker said:
    Ironic_2 said:
    Had the same problem the only way I got it fixxed was by resetting my hdd


    how do i do this? what consequences would i have to face?
    excuse me though, im a pc newbie, willing to learn more.


    It will pretty much delete all of your files except windows


    Does it help that I have a boot drive and another drive to stora my files on?
  5. Best answer
    Why did you uninstall the drivers in the first place? Was there a problem? There's no reason to update drivers on a 6xxx series AMD card since it's a legacy card and no new drivers are being made for it.

    If the card is not being recognized, I suggest booting into the motherboard bios with the 6850 installed but the monitor connected to the integrated graphics. Go to the 'advanced' and usually 'chipset' section. You should see that your primary display adapter is the integrated graphics but also that the 6850 is detected. If it IS being detected there, disable the integrated graphics and save your changes. Now shut down and connect the monitor to the videocard. Boot up in to Windows and install your drivers, the correct ones I hope.
Ask a new question

Read More

Drivers Graphics Cards