Solved

HDD not detected after installing Win 10 in SSD

Hi,

So i installed my Win10 OS on my new SSD(ADATA msata 256gb). During the install I removed my HDD from the laptop. Installation went clean and OS was booting. I reconnect my HDD and restart. The OS boots but I am unable to see the HDD. I checked in disk management and it does not appear there also. Please help me with this?'

HP ENVY 15t-j100 i7-4700mq 8gb 1tb
3 answers Last reply Best Answer
More about hdd detected installing win ssd
  1. Hi saurabh116.

    This is a bit weird. Have you checked if the drive is recognized by Device Manager, or at least by the BIOS/UEFI? If no, go ahead and give it a try and if you're still unable to see it check again if you've connected the drive properly (no loose cables or anything like that). If you're still unable to get anything from the drive, I'd suggest that you try connecting it to a different computer, either externally or internally, to see if it's recognized. If it is, go ahead and backup your important files just to be on the safe side and test the drive with its manufacturer's diagnostic tool, to see if there's anything out of the ordinary.

    Hope that helps.
    Boogieman_WD
  2. Boogieman_WD said:
    Hi saurabh116.

    This is a bit weird. Have you checked if the drive is recognized by Device Manager, or at least by the BIOS/UEFI? If no, go ahead and give it a try and if you're still unable to see it check again if you've connected the drive properly (no loose cables or anything like that). If you're still unable to get anything from the drive, I'd suggest that you try connecting it to a different computer, either externally or internally, to see if it's recognized. If it is, go ahead and backup your important files just to be on the safe side and test the drive with its manufacturer's diagnostic tool, to see if there's anything out of the ordinary.

    Hope that helps.
    Boogieman_WD


    So i checked in the BIOS and under RAID it detects the hdd, i connected it using the external connector and it is detected. The HDD is formatted and has three partitions. I accidentally formatted it and then recovered data using recuva. I reinserted the HDD and when i booted it, the black screen came up with the message "Install an OS in your HDD". I hope I have narrowed down enough. Currently using the lap without the hdd.
  3. Best answer
    Well, it sounds like the OS might have been corrupted if you're getting this message. The good thing is that you were able to recover your data. Now go ahead and test the drive for errors and bad sectors as already suggested.
    You could also try resetting your BIOS/UEFI, to see if that will help for the drive to be recognized by your mobo regardless of the SATA mode you've selected.
Ask a new question

Read More

SSD Storage Hard Drives