Solved

Tried everything, computer still won't post

So I recently built up a new computer, and I can't get it to post. I have a new mobo, memory, and CPU. Using my old GPU, PSU and HDD, so I know those work. I can get 1 long, 2 short beeps when I only have CPU in the mobo and HDD plugged in. But when I plug the RAM back in, I get nothing. No beeps at all. I've spent the better part of the day building this all together, and yes, I've already breadborded it. I couldn't figure out the problem there. Maybe I didn't do something right? Any help would be great.

New Components:
ASUS Z170-A mother board
16gb of G.Skillz RAM at 2400mhz (2x8gb)
Cooler Master Evo 212 heat sink
Intel i5-7500 CPU
NZXT H440 case (if you wanted to know)

Old Components:
Gigabyte R9 390 GPU
Seagate 1tb HDD
Corsair CX600 PSU
***all of these worked earlier today on my old build***
10 answers Last reply Best Answer
More about computer post
  1. Best answer
    The board needs a BIOS update to run Kaby Lake CPU .

    BIOS 3007 is needed.
  2. How would I go about doing that then, since I can't use my current computer. I do have a laptop though, if that helps.
  3. You would need a previous Generation CPU , because I don't think that board supports a flash without CPU.
  4. So do you think if I plug in my psu and HDD into my old build (which was AMD) that I would be able to download the proper drivers?
  5. Nope would have to be an intel Skylake. If you ordered a Z270 board it would have been compatible out of the box.
  6. So should I RMA my mobo to get the new one? I have all of the original packaging still.
  7. I would send it back and get a Z270 , that you will be all set.
  8. (RMA is such a dirty word)
  9. Alright, thank you!
  10. BOT Jeff said:
    Alright, thank you!


    Glad to assist , don't feel bad it's been a common issue on here for 2 weeks.
Ask a new question

Read More

Computers Storage Hard Drives Homebuilt