Solved

TRIM does not seem to work on new SSD

Just picked up a new SSD for my laptop. Replaced another SSD where things worked the way they should.

On this new one I'm having an issue with TRIM apparently not working according to the TRIMcheck tool (version 0.7). I have veryfied that I'm using the correct drivers, and have re-installed WIndows three times and tried with different driver versions. Nothing seems to be helping. This is a fresh Windows install, not a clone from the old drive. I'm not reinstalling Windows again, new drive should last a while now, won't abuse it with unnessescary writes.


fsutil behavior query DisableDeleteNotify gives a result of 0.

Drive in question is a Toshiba A100 120GB.

If anybody has a clue what might be wrong, I'd be happy to hear. Thanks.
2 answers Last reply Best Answer
More about trim work ssd
  1. AHCI mode ?
  2. Best answer
    There is nothing wrong with your ssd. TRIM is not an ssd feature. TRIM is a Microsoft Windows feature that was first added to Windows 7.

    There is nothing wrong with the Windows TRIM feature. You wrote: "fsutil behavior query DisableDeleteNotify gives a result of 0." The O means that TRIM is enabled in Windows. TRIM is enabled by default. You would have to go into the Windows Registry and edit it to disable TRIM.

    Here is a link to an article that explains how to properly check TRIM and how to enable if you disabled it for some reason:

    http://www.howtogeek.com/257196/how-to-check-if-trim-is-enabled-for-your-ssd-and-enable-it-if-it-isnt/
Ask a new question

Read More

Windows SSD Laptops