Solved

Ram issue MSI Z97 Gaming 5

Hello Guys,

Today i bought 3 more ram sticks for my pc, i bought this model;
http://www.corsair.com/en/vengeance-12gb-triple-channel-ddr3-memory-kit-cmz12gx3m3a1600c9
And i already have this one:
http://www.corsair.com/en/vengeance-low-profile-8gb-dual-channel-ddr3-memory-kit-cml8gx3m2a1600c9

But i cannot use them all my pc starts up but i get no screen and it turns off.
i tried to use all 3 of my 1st ram but then i get a blackscreen too.
if i want to mix them like 2 of my old ones and 2 of my new ones blackscreen too.
I tried to run 1 of both ram sticks and they both work so there is no problems with the ram sticks.
My mb is also pretty new i bought it a month ago its the MSI Z97 GAMING 5.

This problem is driving me crazy i cannot make it work... could someone help me?

Regards,
5 answers Last reply Best Answer
More about ram issue msi z97 gaming
  1. Your PC has ran okay before attempting to install the new sticks? are you getting any boot at all? or is it just black screen, saying nothing? just a little more context would help :)
  2. PronouncedWiebe said:
    Your PC has ran okay before attempting to install the new sticks? are you getting any boot at all? or is it just black screen, saying nothing? just a little more context would help :)


    My pc turns on but nothing happends with my screen it stays black, no text on my screen it says nothing.
    And yes my desktop ran perfectly before everything inside is pretty new so i can't find the problem myself..
  3. anybody can help??
  4. Wait, are you mixing the new rams with old ones? I suggest only using the triple back you bought, I do not quite understand but you always use same model of ram and same amount of GBs it has. Never mix different rams, doesn't matter if they are from same brand, they have their own speeds, latencies and whatnot. Have you used only the 3 new rams you bought?
  5. Best answer
    Patronz said:
    anybody can help??


    Try pulling all the ram sticks out and verifying that they all run at the same frequency, density, voltage, and latency. The mobo that you have runs dual channel RAM, (at least that's from what i have read) and needs to have identical RAM sticks to operate properly. As the RAM you bought runs at a different Density than your other stick, id reckon that is the problem. especially since the computer boots fine with either sticks in, but not together.

    Try either buying the same 8gb dual channel RAM as you had in your computer before, or buy one more single RAM stick to make a total of 4 sticks. Since your mother board runs Dual channel, id bet the triple channel RAM is causing this issue.

    The other solution, is try to boot into the BIOS and check what your computer is attempting to do to the new RAM. Just mash "Delete" until you get into the Bios. However, im putting my money on the fact that it is simply the wrong RAM sticks for the motherboard.
Ask a new question

Read More

RAM MSI-Microstar Gaming