Solved

No motherboard LED light after installing brand new SSD

Hi, I need help. I bought a new Samsung 850 EVO last night and I connected it to my system with all the correct cables. After carefully checking all of the wirings I was ready to go. Then suddenly the PC won't turn on. No motherboard green LED. Checked the power cable, no problem. Case wiring, all good. Mobo parts plugs, check. I only actually made changes to the SATA cables and nothing else but, here I am facing this power problem. Could it be that my PSU has finally retired after 3 years?

My current specs (not overclocked):

Intel i5-3570K 3.4Ghz
ASUS P8Z77-M
8GB G.Skill Sniper (2x4GB)
Sapphire Radeon 7870 Ghz Edition
WD Caviar Green 1TB
Thermaltake TR2-600W
Samsung 850 EVO 500GB (BRAND NEW)

Any help would be appreciated! Thanks!
8 answers Last reply Best Answer
More about motherboard led light installing brand ssd
  1. Did it go before?? Or is this a new build?
  2. Best answer
    First make sure the power is connected from the wall to the PSU and the PSU switch is on. Try unplugging the SSD to test if it fixes the issue. Could be a motherboard grounding issue with the case. You may have pressed down to hard causing the standoffs to move around a bit. You can try unbolting the motherboard then try rebolting it down. If this doesn't work try testing the motherboard outside the case. Here is some steps to check to ensure everything is connected.
    http://www.tomshardware.com/forum/261145-31-perform-steps-posting-post-boot-video-problems
  3. Considering it's a TR2 , might have died.
  4. This is an old build (bought 2013). As for the standoffs, I didn't touch them at all. By the way I'm using a Cooler Master USP-100 Mid-Tower. All I did was tinker the PSU cables, that's all.

    I've read negative reviews about the TR2... It MIGHT be the one causing the power problem because everything else was working fine yesterday!
  5. I'll try doing your solution, Elbert. Thanks
  6. I plugged the PC again after doing some errands, and the green LED lit for a while then disappeared again. What does that mean?
  7. SR-71 Blackbird said:
    Considering it's a TR2 , might have died.

    Yeah I think it's dead... Tried isolating the Mobo, CPU and RAM (removed everything else). Still doesn't light up. Will try looking for a better PSU.
  8. Yesterday my PSU suddenly went back to life after I put my hand on it. Apparently all it needed was some grounding (I think) and then, yeah, the motherboard LED went alive. Prior to that I disconnected everything but the CPU and one stick of RAM (I had 2). After the LED turned on I put back the components one by one. Now my SSD is running and drive cloning is done!
Ask a new question