Solved

Samsung EVO 960 M.2 not detected on Asrock X99 I7

I just built my new computer and my Samsung 960 evo m.2 ssd is not detected by the Asrock x99 i7 gaming motherboard. Windows does not recognize the ssd as well. The ssd was just released last week but the specs appear to be compatible with my board.

I have tried disabling the CSM with no luck.

Please let me know if you have any suggestions.

Asrock X99 I7 Gaming
Core I7 6800k
EVGA 1070
5tb HDD
850w EVGA Power
6 answers Last reply Best Answer
More about samsung evo 960 detected asrock x99
  1. Best answer
    Is the M.2 SSD in the M2_2 Slot and not the M2_1?
    The M2_2 should be between PCIe4 and PCIe5 slot, not clearly defined by the manual, but since only this one can support the larger M.2 cards, I guess this is the one.

    It´s a PCIe M.2 SSD which your motherboard´s slot M2_1 doesn´t support, if a CPU with just 28 PCIe-Lanes is installed

    be sure the up to date BIOS is on the motherboard (1.40)
  2. So I tried the M.2 2nd slot and found it in my nvme bios. It allowed me to update the driver then do a fresh install of windows. Looks like I am running pretty good. Thanks
  3. Glad to help
  4. Hey All,

    I have a Samsung Evo 960 that i used as a boot drive, but after a BIOS update the drive is not recognized as a boot device when I power on the laptop and in windows Disk Management as well as in Diskpart or the Samsung Magician Software. It is recognized in the BIOS and show up in the boot menu as well. I haven't got an adapter for the SSD and have only the mother board to plug it in.

    I was hoping someone may know some way to get it formatted so I can Clean install windows back again.

    Or if I can use an PCIe SSD adapter and use the below raiser, and use as an USB enclosure of sorts to get it formatted.
    http://www.ebay.com/itm/371673639335

    Thanks in Advance.
  5. Please Start a new thread, this one is solved.

    In the new thread, post which connection you are using. If it's a M.2, the riser card with pcie won't work. You would need a M.2 one, but please don't. There should be a simple solution for it. Just a setting in the bios. Which laptop is it exactly? And which bios version is it?
    Post this in a new thread and s send me a link by pm
  6. You can find good solutions in youtube by changing from fast boot to slow down detection and change in the Boot management CSM. Thats tricki but it rocks! Asrock must repair the detection function.
Ask a new question

Read More

Evo Intel i7 ASrock Samsung Computers SSD