Terrible performance on new build

I've just started a new build, and after a month of so of the system performing great suddenly the performance has decreased dramatically. An example of this is getting 70-90 fps on the Battlefield 1 beta, and a month or so later having my fps drop well below 30 on the full game.
My build consists of :
Sapphire Radeon RX 470
i3 6100
Kingston fury black 16gb 2133mhz
Asus H110M-K motherboard
EVGA 500W 80 Plus Power Supply
Seagate SSHD 7200RPM 3.5" 1TB

At first i thought it might be the CPU bottle necking the GPU, but my computers previous performance and footage of Battlefield 1 etc. from other peoples builds says otherwise. Also on MSI Afterburner, the GPU usage is constantly fluctuating between minimum and maximum. Help Would be very much appreciated!!!
3 answers Last reply
More about terrible performance build
  1. It sounds like one of three things. Either a virus sucking up your CPU performance since it is already close to bottlenecking you without a performance hit. Larger maps and more players is sucking up your CPU performance more than the beta (unlikely). Or the drivers are messed up in which case use DDU to uninstall them and then try with some fresh AMD drivers.
    Also check what settings you are running in game. Sometimes game updates try to auto set the graphics options again.
  2. What's your cpu and ram usage. There are many people complaining about similar performance issues running i5's. BF1 is currently very CPU heavy, like no game before it.
  3. sizzling said:
    What's your cpu and ram usage. There are many people complaining about similar performance issues running i5's. BF1 is currently very CPU heavy, like no game before it.


    Cpu usage is about 70%, ram is around 50%. Weirdly i had about an hour of the game running solidly over 70fps last night, but since i turned the computer back on the performance has dropped again.
Ask a new question

Read More

Performance i3 6100 RX 470 FPS New Build