Solved

Chkdsk /f on WD My Passport possibly stuck? Any alternatives suggestions?

Hi all,

My wife was having issues with her laptop lagging hard and freezing. I couldn't correct the issue with a couple of basic troubleshooting attempts so I fell back on old reliable, back up the files we need and do a full system restore to factory settings. We had a brand new WD My Passport Ultra 1TB external hard drive, I unboxed it, hooked it up via USB and transferred the files, seemingly successful. I then ejected the hard drive and proceeded with the system restore. The following day i pick up where I left off and with a freshly formatted laptop, I plugged in the external hard drive to pull the files back to my laptop.
This is where I ran into the issue of the drive telling me it needed to be formatted prior to being used when I would try to access it. My wife is flipping and told me this may lead to our divorce (maybe a bit of an over-reaction), but, with all due respect she has hundreds upon hundreds of hours of work on the files that are now solely on that drive.
I tried hooking up the drive to another laptop with the same result. So, after a bit of Google research, I decided to initiate a "chkdsk /f" on the drive. I initiater the chkdsk about 6 hours ago. About 2.5 hours ago it was midway through stage two and read "progress: 5716 of 5984 done; Stage 95%; Total: 70%; ETA: 0:29:18". It has been hung up at this same line sequence for the entire past 2.5 hours with no change at all. Does there come a point where I say "okay...somethings screwed up" and kill the process?
Or are there any other suggestions? I'm open to anything....my marriage may depend on it.

Thanks in advance,
Alex.
2 answers Last reply Best Answer
More about chkdsk passport possibly stuck alternatives suggestions
  1. End that by shutting down if necessary and start again, this time using the /r switch. It's stronger than /f which is only the equivalent of doing it in the GUI and it isn't very effective.
  2. Best answer
    Welcome to the community, @Alex!

    I'm truly sorry to hear about your personal issues what lead to them. :( I'd advise you to try swapping the USB cable connecting the WD My Passport and then check how it appears on both computers. Afterawards, run the QUICK and EXTENDED tests from WD's Data LifeGuard Diagnostics for Windows. This utility will help us determine what is the health and SMART status of the external drive.

    If the files are so important to your wife, I'd advise you to get in touch with a professional data recovery company instead of doing data retrieving attempts by yourself. This is potentially dangerous to the content, especially since we are still not aware of the damage on the WD My Passport. You could refer to our Data Recovery Partners for assistance.

    If this is a brand new WD Passport, you should still check its warranty. If it's covered by us, you should be able to send an RMA request to our Customer Support and get a replacement after a successful data recovery. For more details on these procedures, check the WD Warranty Policy.

    Keep us posted with the troubleshooting & your questions.
    SuperSoph_WD
Ask a new question

Read More

Laptops Western Digital Storage External Hard Drive