Asus Z170 BIOS Update broke RAID 0, 2 Samsung NVMe SSD 950 PRO M.2

Hey guys, looking for some help, trying to recover my raid drives after a bios update. I have Win10 on a Asus Z170 Deluxe board.
After flashing the bios my raid 0 drive no longer shows up in my computer. I have two NVMe M.2 950 Pro SSDs and the computer will not boot up.
It is possible to return my bios to an earlier time/setup?
Any help would be great!
14 answers Last reply
More about asus z170 bios update broke raid samsung nvme ssd 950 pro
  1. Hi, It is, if using the Flashback. Have you changed the setting in BIOS for enabling RAID?
  2. Hi, yes i tried to change the Sata Mode Selection under advanced, PCH Storage Configuration to RAID.
  3. alexoiu said:
    Hi, It is, if using the Flashback. Have you changed the setting in BIOS for enabling RAID?


    Hi, yes i tried to change the "Sata Mode Selection" under /advanced/PCH Storage Configuration/ to RAID. But then both SSDS are not visible under Boot Priority.
  4. Have you enabled M.2 PCIE Storage RAID Support ?
  5. alexoiu said:
    Have you enabled M.2 PCIE Storage RAID Support ?

    Hi alexoiu, yes i also enabled M.2 PCIE Storage RAID support. I will send you some screenshots, maybe that helps to finding out whats configured wrong.
  6. Check also if M.2 and SATA Express Mode Configuration is set to M.2
  7. alexoiu said:
    Check also if M.2 and SATA Express Mode Configuration is set to M.2


    http://imgur.com/a/TgQvh
  8. alexoiu said:
    Check also if M.2 and SATA Express Mode Configuration is set to M.2


    in PCH Storage Configuration or Onboard devices Configuration?

    http://imgur.com/a/OMWH8
  9. Try enabling the PCIEX16_3 PCIE Storage RAID Support and SATA Express PCIE Storage RAID Support too.
  10. alexoiu said:
    Try enabling the PCIEX16_3 PCIE Storage RAID Support and SATA Express PCIE Storage RAID Support too.


    Hi Alexoiu, after I entered the BIOS, switched under "advanced\PCH Storage Configuration" the "SATA Mode Selection" to RAID enabled "Hyper kit Mode", "M.2 PCIE Storage RAID Support" "SATA Express PCIE Storage RAID Support", "PCIEX16_3 PCIE Storage RAID Support" and under "advanced\Onboard Devices Configuration" the "PCI-EX16_3 Bandwith" to "X4 Mode" and "SATA Mode Configuration" to "M.2" the "INTEL Rapid Storage Technology" button was visible again. But after the Reboot the "Sata Mode Configuration" switched from alone from "M.2" back to "SATA Express".
    The INTEL(R) Rapid Storage Technology under "advanced" now reports the array as failed, and the one drive is not marked as being part of an array.

    Is there anything else I can try before I wipe them and start all over?Is there any possibility to repair the RAID 0?

    here are some screenshots.

    Any help would be great!

    http://imgur.com/a/O7Eo0
  11. Hi,
    If switching back from SATA Express to m.2 and disabling SATA Express PCIE Storage RAID Support, still same issue?
  12. alexoiu said:
    Hi,
    If switching back from SATA Express to m.2 and disabling SATA Express PCIE Storage RAID Support, still same issue?


    Hi, yes still the same issue.

    But i have found in another thread maybe some solution.
    It`s an old thread and it was a vista PC with two HDDs in RAID 0 but , do you know if i can use the same solution to repair my RAID 0?

    "I deleted the raid volume, noting the name.
    Rebooted
    Created a new raid volume, naming it the same.
    Rebooted with the OS disc in the tray.
    Did a system repair, and selected startup repair.
    It automatically rebooted and started up normal with all my files intact."
  13. Never tested it, so I don't know if working.
    No other idea, so you can try testing it and, if working, please post back.
  14. alexoiu said:
    Never tested it, so I don't know if working.
    No other idea, so you can try testing it and, if working, please post back.


    Thx Alexoiu, i`ve tried to ask also on the support site of Intel, Samsung and Asus. I´m waiting at the moment to get an answer. If there, i also get no solution i will test it and post back. It`s a nightmare...
Ask a new question

Read More

Z170 Deluxe Samsung SSD Windwos 10 M.2 950 Pro NAS / RAID INTEL RST RAID 0 Asus Hyperkit BIOS