Solved

Motherboard won't detect my HDD drive (Asus H61M-E)

Hi Guys,

I'm trying to figure out if I have a faulty motherboard. it happen all of a sudden, what's happening is my mobo is not recognizing my hard drive anymore. before it was working detecting the drive fine and was able to use my desktop for a week. until one day it won't boot to my OS and its keeps giving me the message. " the current BIOS setting do not fully support the boot device". What I don't understand is the drive is working fine with my other desktop. its recognizing it.

Is this somewhat a compatibility issue?, please see details below.

Troubleshooting done:

- Done updating BIOS
- Done plugging it to a different port on the board
- Done using a different SATA cable

Motherboard: Asus H61M-E
HDD: Western Digital 500GB ( WD5000AAKX )
4 answers Last reply Best Answer
More about motherboard detect hdd drive asus h61m
  1. Welcome To Tom's Hardware, @codelaborator!

    I suspect that the issue is coming from the BIOS settings, rather than a compatibility issue. I'd recommend you check your boot priority and make sure that the HDD is the first option. You should also try booting while in Legacy BIOS and through UEFI BIOS. If your WD Blue HDD has the MBR (Master Boot Record) partition table, you won't be able to boot from UEFI BIOS and vice versa, if your WD Blue is in GPT, you won't be able to boot from it in Legacy BIOS. Usually, MBR and Legacy BIOS (MBR + BIOS), and GPT (GUID Partition Table) and UEFI (GPT + UEFI) go hand in hand.

    Give it a try and let me know how it goes.
    SuperSoph_WD
  2. After I posted this, tried other troubleshooting process. one of it was installing Ubuntu in it with no partition on my other desktop. after installing it, tried it on my faulty MOBO it's working. was able to recognize the drive and boot to ubuntu. but when I tried installing windows 7 it, my MOBO is not recognizing the drive again. so wipe out the drive and install ubuntu again. it's now working. what do you think?
  3. Best answer
    Hey there again, @codelaborator!

    If your WD Blue is initialized with the Master Boot Record partition table and you are booted into UEFI BIOS, then I suspect that Windows will give you an error and that's why you are unable to install that OS. As I already mentioned, Master Boot record partition table and Legacy BIOS (MBR + BIOS), and GUID Partition Table and UEFI (GPT + UEFI) go hand in hand. This is compulsory for Windows OS, for example, while it's optional for other operating systems like Linux. Here's a wiki you might find useful.

    Hope it helps.
    SuperSoph_WD
  4. Thanks @SuperSoph_WD

    I'll read the link to have a better understanding about it. maybe then I'll be able to use windows OS on my drive. I think I just don't understand how it works. I really appreciate the help!
Ask a new question

Read More

Asus Western Digital Storage Hard Drives Motherboards