Solved

Major FPS drop is GTAV - Even with a decent rig

So, I'm having some difficulties right now. No matter what settings I try, I can't get above 35 FPS in GTAV. My rig is the follwing: AMD fx4300, EVGA 750ti, 8 gigs ram. Even if I do manage to get 45 FPS, the game is still "Choppy", which at 40 FPS it shouldn't be.

I've tried many different settings in game, and have tried fooling around with the Nvidia control panel to no avail. I'm attaching a screenshot of my settings.

Well the weird thing is, I used to be able to run everything on medium/high at 60FPS with no problems or choppiness at all. Then I messed with a setting in the Nvidia Control Panel and can't get it to return to normal,


Thanks
8 answers Last reply Best Answer
More about major fps drop gtav decent rig
  1. Honestly your gonna have problems with your CPU and GTA V it's horribly optimized as far as CPU usage goes.
  2. Not only that but the 750TI isn't really up to the challenge. You may get bursts of playable FPS, but its going to fall behind often.

    I played GTA V on an old Phenom II, but I also had an r9 390 which was quite the powerhouse when GTA V came out. Even then it was not perfect, and the 390 blows the 750ti out of the water.
  3. you're not gonna like this answer probably but that is a low end system these days. 35 fps on normal sounds just right to me. so does the choppiness.

    what i CAN say is that this past week i noticed a big jump in smoothness and fps just by overclocking my ram from 1333mhz to 1600mhz...which ive never seen before in a game....but this is on an i7 4770k and a gtx 970
  4. Yes, for modern gaming, that rig is far from 'decent'. GTA V is especially demanding.
  5. dangus said:
    you're not gonna like this answer probably but that is a low end system these days. 35 fps on normal sounds just right to me. so does the choppiness.

    what i CAN say is that this past week i noticed a big jump in smoothness and fps just by overclocking my ram from 1333mhz to 1600mhz...which ive never seen before in a game....but this is on an i7 4770k and a gtx 970



    Well the weird thing is, I used to be able to run everything on medium at 60FPS with no problems at all. Then I messed with a setting in the Nvidia Control Panel and can't get it to return to normal,
  6. Best answer
    With a good cpu, a 750ti should be good for 45-55fps on normal settings at 1080p.

    http://www.techspot.com/review/991-gta-5-pc-benchmarks/page2.html

    The 4300 will hold you back somewhat..
  7. what kind of display are you using with your pc? i see that the resolution in-game is set to 1914x1080 which is odd.
  8. also, try setting the priority of the game to "high" in task manager
Ask a new question