Windows 7 Setup Won't Recognize SSD or Hard Drive after (botched?) BIOS update

Brief Statement of Problem

After a botched BIOS update (computer shut down during update), the computer wouldn't boot up, stating it couldn't find an operating system. I tried to reinstall Windows 7, but the setup program won't recognize either of my internal hard drives or the internal SSD which was Win7 installed and is my boot drive - it does recognize my external (backup) Mybook Duo but that doesn't help me here. The SSD and both internal hard drives still show up in CMOS and Partition Wizard, however. How can I get Windows setup to recognize my hard drive so I can repair or reinstall Windows?

Note: I borrowed pieces of this post from another one I found online from Dec. 2015 since the circumstances mirror mine closely. In that case, the answer that seemed to work for the poster was to go to Dell support, download the latest SATA RAID drivers and put them on a USB drive, then load them in when requested by the Windows install program. I tried doing that but, assuming I have the right drivers, nothing shows up in the Windows install box even after loading in the latest drivers that I found and put on USB from Dell.

Computer Specs

Alienware Aurora R4 desktop, purchased from Alienware March 2013
CPU: Intel Core i7-3820K @ 3.6GHz
RAM: 16GB Quad Channel DDR3
Primary Hard Drive: 2562GB SSD (ATA SAMSUNG SSD PM83 SCSI Disk Device)
Secondary (Storage) Hard Drive: 2TB internal factory installed (Western Digital)

Tertiary HD: 1 TB (I installed myself since I had an extra, the setup has worked fine for years)
GPU: NVIDIA GeForce GTX 660
OS: Windows 7 Home 64 bit (not sure if Premium version?)

Drives are not in a RAID configuration.


Troubleshooting History

After almost three years of problem-free use, my fans were running really high and loud all the time - including while at rest and I rarely do anything CPU/GPU intensive. Based on information found online, I downloaded and installed the latest version of Alienware Command Center/thermal controls. That did not solve the fan problem and in fact the thermal controls weren't giving readings any more - basically said that the CPU pump had failed and everything showed as 0 degree Celsius. Based on information from the support forums, I decided to upgrade the BIOS (from v.7 to v.11) using the updater downloaded from the Dell support site [perhaps a bad idea in retrospect, I'll admit, but even manual fan controls weren't helping the issue].

As the PC was rebooting during the BIOS update, the computer fans started running at a really high speed -- much faster than I'd ever heard before. I was worried my computer was being damaged but I let it go for a long time nonetheless. After about 5 minutes I stupidly forced a computer shutdown. [Yes, I know, that was really, really stupid - although based on the fact that my computer does boot up to BIOS and from what I've seen online elsewhere it appears the BIOS update went through, albeit with messed up settings.]

After that, the computer wouldn't boot up. The error message stated that BOOTMGR was missing. I downloaded partitionwizard on the thought that this was an MBR/partition issue and, sure enough, both my SSD (marked as "boot+active") and a secondary drive were marked active. I made the second drive "inactive". Partition Wizard also does show all of my drives, including their partitions, correctly.

While troubleshooting, I had also used my Alienware install disk and tried to either repair or re-install Windows. In all cases, the Win7 setup/repair program could not find any hard drives or operating system. When I went to the command prompt from the install disk and tried DISKPART "list disk" or BOOTFIX.EXE, they only listed my external MyBook Duo (which I've since unplugged, and now no drives show up) - I've never seen the internal boot SSD or either of the other internal drives while at the Windows 7 install program. Using the various BOOTFIX.EXE options like /fixmbr and /scanos don't help - they either complete "correctly" really quickly to no effect or tell me no OS is present.

Now when I try to load up, I don't get the BOOTMGR message anymore but instead get one about there being no boot device present and how I should insert boot media.

I then tried using the Alienware Windows 7 disc again to reinstall Windows 7, but the setup program still couldn't find a hard drive.

I've also tried installing Windows via a bootable USB drive, but had the same result.

I can get into CMOS setup just fine. I can make and save changes to it just fine. It looks normal, and it properly lists all three internal hard drives. POST also properly lists all of my hard drives.

I have seen reference to changing the RAID settings in the CMOS setup but my only two options are RAID or ACHE and neither of those changes the situation.

I would be fine with reinstalling Windows 7 on the SSD drive (would prefer not to, ideally, but it's just a boot drive with some Steam games on it so easy enough to recreate). I do have my documents from the other internal drives backed up but I haven't seen anything that makes me think those drives have been affected, just that I need to get the internal drives recognized somehow. Is it as simple as somehow getting the right drivers loaded in and, if so, how do I do that (I have previously downloaded all three files that Dell lists under "storage device" and "drivers" on the support page and unzipped them to a USB drive and used the install disk's option to load them in, but that doesn't result in the operating system showing up so install/repair can access it)? Or am I missing some other step?

Please let me know if screenshots or more information would be helpful - happy to provide them once I'm home and back in front of that computer.

Thanks in advance!
2 answers Last reply
More about windows setup recognize ssd hard drive botched bios update
  1. Have you already tried booting from your installer disk and running a system repair?
  2. I have (mentioned above in the Troubleshooting section) - that's when nothing showed up in terms of recognized operating systems and when I tried to load in the SATA RAID drivers from Dell to no avail. I also booted from that disk and used the "command prompt" option to get to the command prompt where I tried the DISKPARK and BOOTFIX options.

    Because the drives don't appear to be registering, when I run the system repair function from the install disk, it runs for a bit and then reboots but nothing more has happened - I've done this a number of times since I saw reference to possibly needing to go through the repair cycle 3-5 times, but nothing has changed in terms of the error message I get (when I boot without the install disk) or in terms of what shows up when I try to run the repair function and/or see what shows up in DISKLIST "list disk".
Ask a new question

Read More

Windows 7 Dell-Samsung SSD Hard Drives BIOS