Issues with 4K monitor and 1080p Monitor not displaying correct resolution

Hi Guys

Long time lurker here checking solutions for problems but i can't seem to find a fix for this weird issue. Let me start from the beginning.

Ive had a two monitor setup on my old 7970 which had ran fine, one day when i came to boot the PC on the resolution had changed to 640 x 480 (supposed to be 1080p) and my main monitor which is 4k had changed to 1440p with no options to go any higher

i cannot edit the 1080p monitor as the settings are greyed out

and the 4k monitor only lets me go to 1440p

I had tried different Drivers and still the same, different cables, tried running only one display , power cycling you name it.

after awhile I had just accepted it as possibly a dying card and decided id go out and buy 2 480s as a gift to myself

after wiping the entire system clean i reinstalled the latest AMD drivers and sent it to restart and boom, its doing the exact same, now the only reason i don't suspect drivers is i tried some from 2 years ago for the 7970 and it still did it, and considering the drivers worked fine for months before suddenly one day deciding to change its resolution i cant see it being that

You guys got any ideas?

Specs for Monitors are

AOC U2879VF 28" FreeSync 4K Monitor

Samsung s22a350h

i have also attached some screenshots below





1 answer Last reply
More about issues monitor 1080p monitor displaying correct resolution
  1. Progress!

    I have unplugged the Samsung and restarted,

    I now have 4k again on main monitor

    i have tested Samsung now with laptop and it just keeps going from analog to HDMI with no display then it just gives up, you think the monitor is past its expiry date?
Ask a new question

Read More

Drivers Resolution Monitors AMD