Solved

[Please Help]- PC won't show signal on display(though the gpu amd r9 270)

Hello,
I have been having issue with my PC lately it sometimes switches off my monitor somehow and when I power it up I get no signal till I replug the HDMI or restart the PC and then I would get multiple displays shown on my display settings yet it's only connected to one. I thought it was something to do with Windows 10 drivers or something. Till one day it happened and I haven't been able to get anything show on my screen I tried to other displays also. My Samsung display gets a signal for a few seconds still showing a blank screen then I get no signal come up and the TV still detects my HDMI plugged in. I reset my CMOS , and also took out the ram and placed it back I , also took out the gpu and put it back in also replaced the thermal paste on the gpu, I took out the hard drive and replaced it with another.

P.S. I can't try motherboard outputs due to the fact my apu has no gpu it's a amd x4 750k
Specs:
Amd athlon x4 750k black edition
Gigabyte - amd r9 270 2gb gddr5
Gigabyte -f2a88xn-wifi itx fm2+
4gb ddr3 x2- Kingston hyper fury 1866mhz
Wd- blue 1 TB HDD 64mb cache 7200rpm
500w EVGA bronze plus PSU
~Please help :??:
2 answers Last reply Best Answer
More about show signal display gpu amd 270
  1. Best answer
    Going to have to suggest trying a new GPU at this point. Makes it a bit hard because you are using a CPU and not an APU. Have an extra GPU or a friends you could borrow?
  2. inerax said:
    Going to have to suggest trying a new GPU at this point. Makes it a bit hard because you are using a CPU and not an APU. Have an extra GPU or a friends you could borrow?


    I will try get one maybe off my cousin.
Ask a new question

Read More

GPUs Displays AMD