Solved

Need Help external HDD can't open some data

i have been using this thing for a while and it worked perfect, until recently i save a work on microsoft word and then save it to the hard drive but when i try to open it on one of my friends notebook, thats when the problem starts. it can't open and then i try to use another laptop with better speed and it still can't open, i tried to copy it to the laptop but it only says calculating for a very long time but then i tri to open it and waited like 15 minutes for a 1,7 Mb file to open... -.-"
its not even fully loaded but luckily i was able to re-save the file to the laptop and then copy it to my HDD (i thought this was USB virus),but then i used the computer and the opening procces was good again, so i thought that was just a minor problem because of the laptop with low specs..
after that i copied another data (23 parts) with 22 Gb size its all normal until part 22 the problem starts again, so i try to search for another part 22 then download it and its working normally again.
with that out of the way i'm copying another file around 800 mb but the problem starts again it can't proccess the data. so i tried error checking on the HDD but it doesn't proccess any data, i also tried to analyze and defragment but it wont start.. its not doing anything..
the error seems spreading to some data now
can anyone helpme why the harddisk is becoming like this and how can i fix the harddisk?
is it because of bad sector

update :
from what i know if its a bad sector... then the copy should've become slower not completely stuck, but i can access the file normally like any other file but i can't open it or copy it.
i've tried chkdsk and it stuck at the beginning, its not processing any file
4 answers Last reply Best Answer
More about external hdd open data
  1. Hi there Spectatroll,

    Unfortunately, there's a chance that the drive is failing. This is why, my suggestion would be to try to back up the data stored on the drive(much data as you can).
    If there are some files that you can't transfer, it may be a good idea to give the Ubuntu Live CD approach a try. Just boot up(don't install it) Ubuntu from a CD or a flash drive and see whether you will be able to access the drive and transfer the data. Ubuntu could be useful in similar cases. Here's a thread on that: http://www.tomshardware.co.uk/forum/267999-32-recover-data-mode

    After that, you can switch back to Win and test the drive with a tool that can provide a SMART report: http://www.tomshardware.co.uk/forum/282651-32-best-diagnostic-testing-utility
    This would eventually show what is wrong with the drive. In case there are some bad sectors on it, then the drive is going to fail.(can't really know when)

    Let me know how this goes,
    D_Know_WD :)
  2. aaaaand, it can't be tested... the scanner completely stuck at 0 and the SMART shows that the drive had some unstable sectors

    i tried self test and it always got a "read failure"
  3. Best answer
    It seems that you will need to replace the drive. If it is under warranty, you can just RMA it.
    In case it is not, you can use it for storing non important data.

    D_Know_WD :)
  4. i tried to find any solution by by far there's none sooo yeah.... it is sad that it couldn't be fixed
    but its been a while soooo thanks for the help
Ask a new question

Read More

Laptops Storage External Hard Drive