Solved

HDD disappeared from My Computer but visible in Device Manager

Until last night everything was working perfectly, but today i booted up my computer only to find one of the HDDs missing. It has completely vanished from My Computer, although i can still see it in Device Manager.

I searched online and the only similar issue people have had, appears to be when they install a new HDD or when upgrading from a previous version of windows. I've been using this hdd for a long time (on Windows 10), and just today it disappeared.

I don't want to format it, as i have tons of things on it. In Disk Management, i can see the drive but it doesn't have a letter like the rest, it just says Disk 1 or something.

How can i access my drive again and why did this happen?
7 answers Last reply Best Answer
More about hdd disappeared computer visible device manager
  1. so in the box that represents drive in disk management, does it say anything? Even if its blank it should have total space + unallocated written under neath it.

    can you link a screen shot of disk management?
  2. I just checked it again, and i noticed it says capacity is 50GB, and free space is 50GB(100% free), which is impossible since the drive had a lot of things on it, and it's not 50gb to begin with! It's a 1.5TB drive.

    Unless im looking at the wrong drive, but i don't think so. All my other 2 drives, one ssd and one hdd are listed there with correct info, so i assume the hdd in question is the blank one with the wrong info.

    Check out the picture for yourself
    https://gyazo.com/0cf448b28e3067c42b2cf51aa27e2189

    One last thing i noticed, is how in the upper list the type of all drives is Basic, but lower down at the boxes, "Disk 1" is displayed as Dynamic, and also says "Errors".

    Has the HDD died? The assigned letter of this drive used to be "E".
  3. Best answer
    Disk 1 in shot isn't even showing at all. Did you ever have raid?

    differences between basic discs and dynamic: link

    this might help: another one
  4. Disk 1 isn't even showing at all and that's exactly the problem. It shows up in device manager as working, and in bios too. Until last night the drive didn't have any issues whatsoever. I've never had raid.

    I already tried reactivating the drive, making it offline and online again, disabling/enabling from device manager/bios, tried to access it from disk management, and pretty much looked everywhere for someone that's had the same issue, without sucess. Looks like this has only ever happened to me.

    Anyway, in Disk Management, i right clicked Disk 1, chose Convert to Basic, and the drive's space appeared correctly again. Then i formatted it to ntfs and it started working again. Shame that i lost more than a terrabyte worth of installed games and ripped bluray movies. Nothing i can't recover, but still.

    I'm afraid this will happen again. Any ideas at all, why it occured?
  5. try running these two on drive and see how it performs

    http://www.hdtune.com/download.html (download trial)

    http://crystalmark.info/download/index-e.html

    what brand is the drive? some makers have drive testing software.
  6. Crystal disk already displays the drive in "good" condition: https://gyazo.com/7a7d22c805bc4d86246d9ff85a50dd10

    I'll try running hd tune. The drive's brand is samsung.
  7. before you copy anything onto drive, maybe you should format it as GPT as then it might not loose its partitions again.

    Quote:
    Convert MBR to GPT using Diskpart
    This method you have to backup all your data and delete all partitions and volumes. Then use the DISKPART command.

    Open command prompt and type in DISKPART and press Enter
    Then type in list disk (Note down the number of disk you want to convert to GPT)
    Then type in select disk number of disk
    Finally type in convert gpt.


    http://www.thewindowsclub.com/convert-mbr-to-gpt-disk

    love that theme in crystaldiskmark, its unique i guess.
Ask a new question

Read More

Device Manager Computers Storage Hard Drives