Solved

Corrupted Management Engine Causing Missing Overclock Options?

Recently, I upgraded from 8GB (2x4GB) 1866MHz RAM to 16GB (2x8GB) 2133MHz. At some point during the process of testing different memory timings and voltages on this new RAM, memory speeds above 1333, CPU ratios above 37, XMP, and a few other less important settings disappeared from the BIOS/UEFI. In the case of CPU Ratio, the Per Core setting (not that I ever used it) is gone, and setting All Core to anything over 37 reverts to 37 (I had been using 45 for years, so I know this wasn't previously a problem). XMP is gone and the only available DRAM Frequencies are 1066 and 1333 (previously, I was using 2133).

I've read elsewhere from people with similar issues that this is supposedly caused by the Intel Management Engine that's embedded (or whatever) in the BIOS/UEFI becoming corrupted, but don't know if this is the case.

I've tried flashing all previous BIOS versions for my motherboard back to 1.30 (starting at L2.31A, which is what I had been using all along), and replacing the old RAM. None of which changed anything. I've contacted ASRock technical support, but they're clueless. I seem to be far more technically proficient than they are.

What can I do to fix this? I've already ordered a new BIOS chip, but I'd like to know what caused the problem to begin with and/or how to fix it so that this doesn't happen again.

Motherboard: ASRock Extreme3 Gen3
CPU: Intel Core i5 2500K
RAM: G.Skill 8GB (2x4GB) 1866MHz/G.Skill 16GB (2x8GB) 2133MHz
Video Card: Sapphire Vapor-X R9 290
Sound Card: Creative X-Fi Titanium
HD: Samsung 850 Pro 256GB SSD
OS: Microsoft Windows 10 x64
1 answer Last reply Best Answer
More about corrupted management engine causing missing overclock options
  1. Best answer
    1| Have you tried ruling out that the OS is the culprit by downgrading to a previous known functioning OS like Windows 7 since you're on the Sandy Bridge platform...?
    2| When on Windows 10, try reinstalling your OS and disable automatic device driver updates and manually install all your drivers.
    3| As a last resort you can try and install your Intel MEI drivers in compatibility mode:
    Right click installer>Properties>Compatibility Tab>Windows 7 [from drop down menu]

    * If you are on a Z68 Extreme3 Gen3 board:
    http://www.asrock.com/mb/Intel/Z68%20Extreme3%20Gen3/?cat=Download&os=Win1064

    I'm pretty sure the OS is what's causing a havoc with your system for which the last and only hope would be to downgrade to last working OS if the above are a no go.
Ask a new question

Read More

me ratio ASrock mb Motherboards mei BIOS intel management engine management engine uefi corrupt xmp corrupted