Solved

My HDD light turns off after 20 minutes of use?

Hello,

So I had just passed my 6 month of having this computer, and lately it's been acting up. The HDD light has been blinking way too much, and I haven't been too worried recently, but I'll get to a really relaxing point into sitting down. Give it 20 minutes from first powering on and the screen completely freezes. The HDD light? Gone. It's not even flashing, but the power light is. I've looked around and tried to find solutions. I've monitored my Ram usage, CPU temps, and my wiring, they're all fine to me. CPU temp is around 13 degrees Celsius and my computer died when about 40% of my ram was used. The weird thing about this is that the light slowly dies off; when I first power it on, the light is strong and doesn't blink, but when I watch it, it slowly begins to blink and then the blinks become longer apart. Then it stops and the pc freezes. Does anyone have any idea why this would happen and how I could fix it?

Thanks
3 answers Last reply Best Answer
More about hdd light turns minutes
  1. Hi there Prezeo,

    My advice would be to back up the data stored on the drive until you sort this out.
    After that, you can try several things:
    - Attach the drive with different cables(SATA & power ones) to another SATA port.
    - Test the drive with a brand specific or a third party testing tool that will provide a SMART report.
    - Go to your MOBO's website and update its drivers.

    Let me know how this goes,
    D_Know_WD :)
  2. D_Know_WD said:
    Hi there Prezeo,

    My advice would be to back up the data stored on the drive until you sort this out.
    After that, you can try several things:
    - Attach the drive with different cables(SATA & power ones) to another SATA port.
    - Test the drive with a brand specific or a third party testing tool that will provide a SMART report.
    - Go to your MOBO's website and update its drivers.

    Let me know how this goes,
    D_Know_WD :)


    Hey, sorry for taking FOREVER to respond:

    So I ended up doing what you said about re-wiring some of the different cables and changing SATA ports. My PC seemed to be working perfectly after that. But now recently it's been doing the same thing. I just bought a Need For Speed game and once I downloaded it I began playing it and after about 15 minutes everything did as it did before; it froze and the HDD light was off. I just rewired the cables again but it did the same thing about 20 minutes later. I've come up with some ideas but tell me if I am wrong. One idea is that I don't have enough ram to run the game, the requirements read that I need at least 250mb of ram to run the game, but I have 2 gigs. Another idea is that my SATA cord is bad, but I don't see why it would be because it's basically brand new. ANOTHER idea is that there's something wrong with my mobo. My drivers are all up to date and it seems fine to me.

    I am probably going to purchase more ram because one, I really REALLY need it and two, i'd like to see if this fixes my problem. I will let you know on that. If you have an idea on what is going on, let me know!

    Thanks!

    P.S. Do you recommend any testing tools I can run? If so, PLEASE link me!
  3. Best answer
    Have you changed both SATA and power cables? You need to try a different power cable as well.

    Well, I don't think that this HDD disconnection is related to your RAM. Yet, it is always a good idea to add some more.

    If the issue persists even after using different cables and ports, then it could be PSU or MOBO issue.(if the drive is in a healthy state)

    Here are some tools that you can use: http://www.tomshardware.co.uk/forum/282651-32-best-diagnostic-testing-utility

    Cheers,
    D_Know_WD :)
Ask a new question

Read More

Light Computers Hard Drives Components