Asus Z-170E won't post and boot device led stays red

I have a Asus z-170e with an i5-6600k and a coursair 750 watt PSU. No GPU yet it's on its way. I have a Samsung 120gb ssd and a 212 evo cooler.
When I press the power button the board runs through all its tests (no video) with the LEDs on the board. Goes through all with no issue except for the Boot device led. That remains red and on for a few seconds before the system shuts down. I've reseated RAM, tried difruent SATA cables tried different power cables. Still no video signal and still no luck with the BIOS menu showing up. Boot led light is still on and nothing changing. Anything else I can do or do I need to send it off and get a new board? I bought this one off NCIX. If I need to RMA it where do I start?
2 answers Last reply
More about asus 170e post boot device led stays red
  1. It could be bad ram or ram that is not compatible.

    Test boot with 1 ram stick, try all the sticks. Usually only one ram stick is bad.

    Double check the compatibility of the RAM.

    What ram did you get?
  2. I called tech support at NCIX and they diagnosed it as DOA.
Ask a new question

Read More

Asus Video Games Boot LED Monitor