Solved

Asrock z79 Extreme 4 MOBO Won't Post After Computer Turned Off.

Specs:
CPU: intel i7-4770k w/ stock cooler
GPU: EVGA GTX 960
RAM: G. Skill Rip Jaws X. 4GB*2 (8)GB ram 1600 Mhz DDR3
HD: Kingston Hyper X 120GB
MOBO: Asrock z97 Extreme 4 LGA 1150
PSU: 500W Corsair
Case: NZXT s340
OS: Windows 8.1 64-bit

So this is now the second MOBO that has "died" on me in the past 3 months. The previous one was an MSI board. When I turn on the computer all fans spin (case, CPU and GPU) but no video output or error code. Tried holding down cmos reset to no avail. I recently tested the PSU when my last board died (approx. 1 month ago). Also another thing to note is that only certain USB devices power on such as USB HDD and Headset but not keyboard or its lights. I tried changing the DVI output to my MOBO and using integrated graphics + removing the GPU but still no codes/post. I also tried booting off no RAM, 1 stick as well as changing to different dims but still nothing. I'm not sure if something in my case is causing my MOBO to short or if the paperclip test with the PSU could still mean a dead PSU. Please help!

Additional notes: - NZXT S340 case has built in standoffs and all case screws securing motherboard have been checked
- I do leave my computer on overnight fairly often (4/7 days a week)
- Have checked for mobo heat with my hand but nothing seems to be extremely hot
- When I tested PSU with paperclip it worked on both case fans
- Have yet to try locating another 8 pin connector from PSU and try that one instead.
1 answer Last reply Best Answer
More about asrock z79 extreme mobo post computer turned
  1. Best answer
Ask a new question

Read More

Boot Failure Computers Motherboards