Solved

Bios & Device Manager detect 2nd hard drive, but Disk Management does not (Windows 10)

I purchased a 2TB Seagate Barracuda this week for internal mass storage in a new build and Disk Manager will not detect it in order for me to format it for use. The weird thing is, device manager does seem to detect the drive. I tried to disable and renable it. I've also tried the unplug>restart pc>shutdown>plugin process but it didn't help either. The drive also could be found in the bios. I've even tried formatting the drive on my personal rig and even there I ran into the same issue. The rig I'm working with has a GA-Z170x Gaming 3 motherboard by Gigabyte with a Core i5-6600K. I added a screenshot for additional visual aid. Any insight on the issue is greatly appreciated. If it's a drive issue, I will return it since it's still under the return policy.
4 answers Last reply Best Answer
More about bios device manager detect 2nd hard drive disk management windows
  1. So you connected the Seagate HDD as a secondary disk to two different PCs and the results were the same in that while the drive was detected in Device Manager in both cases, it wasn't listed in Disk Management in either PC. Of course you used different SATA data connector cables for each PC that the drive was connected to, right? So do I have all this right so far?

    If that is the case you should test the disk with Seagate's SeaTools HDD diagnostic tool. It's conceivable you may have a defective disk on your hands. It's a first (and perhaps last step) depending upon the results of the test.

    BTW, there was no screenshot (Disk Management?) included with your post.
  2. ArtPog said:
    So you connected the Seagate HDD as a secondary disk to two different PCs and the results were the same in that while the drive was detected in Device Manager in both cases, it wasn't listed in Disk Management in either PC. Of course you used different SATA data connector cables for each PC that the drive was connected to, right? So do I have all this right so far?

    If that is the case you should test the disk with Seagate's SeaTools HDD diagnostic tool. It's conceivable you may have a defective disk on your hands. It's a first (and perhaps last step) depending upon the results of the test.

    BTW, there was no screenshot (Disk Management?) included with your post.



    you are correct. I used different cables and the cables I used from my computer to connect the non functioning drive were the same cables I used for the drives already in my personal rig. Sorry that my image didn't post. I will just post a link here. http://imgur.com/8sVdDYQ

    I contacted support at Seagate and the rep helping me said he suspected it was the drive itself because he had never seen an instance like that. I am likely going to exchange the drive for a new one.
  3. Best answer
    It's probably for the best that you return the Seagate HDD for a replacement. I assume that since you purchased the disk this week you can obtain a replacement from the vendor who sold you the disk. Presumably this replacement would be a brand-new identical model. I mention this because all too frequently when it's an RMA situation and the replacement is made by the manufacturer, they replace the drive with a refurbished model rather than a brand-new replacement.
  4. ArtPog said:
    It's probably for the best that you return the Seagate HDD for a replacement. I assume that since you purchased the disk this week you can obtain a replacement from the vendor who sold you the disk. Presumably this replacement would be a brand-new identical model. I mention this because all too frequently when it's an RMA situation and the replacement is made by the manufacturer, they replace the drive with a refurbished model rather than a brand-new replacement.


    It seems like the best solution for me at the moment. Thanks for you help!
Ask a new question

Read More

Device Manager Disk Management Hard Drives