Solved

HELP! PC won't post, red DRAM led lit, tried everything I can think of, suggestions please!

Hi All, long time lurker but first time poster here.

Came home last night to a PC that suddenly and mysteriously won't post (blank screen) after a few months of trouble free operation and I am looking for ideas for things to try as I am completely at a loss. After opening the case I noticed the DRAM LED is lit solid.

My build:
i5 6600k (Noctua NH-D15 cooler)
Asus Z170-A (bios v0701)
MSI GTX 970 4GD5T OC
G.Skill Ripjaws V 16GB (4x4GB, F4-3200C16Q-16GVK)
Samsung 850 EVO 500Gb
Seagate Barracuda 3TB
LG Blu-ray reader/DVD burner
Corsair RM850i
Fractal Design Define R5

What I have tried so far:

- I of course checked all connections were secure first.

- Opened up the case and found the DRAM LED lit solid. Tried re-seating the RAM and pressing the MEMOK! button.

- I then tried changing the DVI cable then tried a second monitor (both cables and monitors work with my second pc).

- At this point I replaced the Noctua cooler with a cheapie Deep Cool cooler to make things easier, that Noctua cooler is massive! Removed all the RAM then tried all four sticks in the DIMM_A2 slot individually per the motherboard user manual recommendation and tried hitting the MEMOK! button for each stick aswell. Then tried the same for the DIMM_A1/B1/B2 slots aswell , then tried the same for permutations of two sticks in A1+B1 or A2+B2.

- pulled the video card and connected to the motherboard DVI connection

- Tried clearing the bios settings via the CLRTC pins

- Tried again to clear the bios by removing the motherboard battery for a few hours plus the CLRTC pins

- Disconnected/removed everything until there was only the motherboard, CPU+cooler, a single stick of RAM in the A2 slot ,power supply and case power switch connected.

- Connected a second power supply in the same configuration as above. Tried a few sticks of RAM and MEMOK! button again.

- Removed the motherboard from the case and tried again in the same configuration as above. Tried a few sticks of RAM and MEMOK! button yet again.

- I even tried disconnecting the CPU cooler fan.

The last thing I can think of is to try to flash the bios via usb but that is a last resort step since it could actually kill the MB, especially if there is something that's not right to begin with...

Any ideas at all would be welcome!

I don't have access to different RAM, Motherboard or CPU short of going out and buying new ones.

Total disclosure:

- The RAM I have is not listed on the Qualified Vender List by Asus for the Z170-A motherboard but it is listed as being successfully tested with this Motherboard by G.Skill and it worked fine for the first few months of operation.

- My CPU has been overclocked and stable for the entire time I've had the PC

I am also worried about the CPU since there were some news items about some coolers damaging the skylake CPUs but my pc never gets moved and Noctua always stands by their product so...

Thanks in advance for any help that anyone can offer!!
5 answers Last reply Best Answer
More about post red dram led lit suggestions
  1. Best answer
    You've troubleshooted the heck out of that thing. I think it's pretty safe to say the it's either the motherboard or CPU. Normally I would say RMA the board, but Iv'e seen a few failed Skylake CPU's lately and one had the same cooler. Try the CPU in another system if you can to rule it out first. I don't think the Bios is going to have anything to do with what your experiencing.
  2. thanks for the quick reply BadActor, I just thought that a bios update might bring some stability fixes that could help especially with RAM that hasn't been officially tested by Asus... plus I've run out of other things to try...
  3. If it's been working for months, and suddenly stops with a memory debug light and you've went through the troubleshooting procedures thoroughly like you have, I can't see compatibility being the issue. I would be more inclined to think the memory controller on the CPU or some component of the motherboard has failed.
  4. Yep, brought it over to a buddies place and swapped my CPU into his motherboard and it wouldn't post either... fault found
  5. That's good....and bad. Let's just hope it was a fluke.
Ask a new question

Read More

DRAM LED Monitor Memory