No display on monitor after installing a new graphics card

Hey guys , so I just got a new graphics card for my pc

Specs are:
Motherboard: Asus M5A78L-M/USB3
CPU: AMD Phenom X4 965
Graphics card: AMD Radeon HD 7850 (the new card)
Ram: 1x4gb stick (Brand unsure, bought for old setup)
Power supply: Corsair CX600

I uninstalled my old cards drivers and shut down my pc , slotted the new one into my pci-e slot and connected the 6-pin power cable and the hdmi , the when I attempt to boot my pc , the cards fans spin for a sec (not sure if some sort of power saving function) and nothing displays onto the screen , my bios graphics settings are set to boot pci graphics first and I'm stumped as to what i should try next , everything seems to be running as usual in the case and my mouse lights up showing that it is actually booting up but no picture. Its pretty frustrating , let me know if you guys have any ideas about what to do next.
2 answers Last reply
More about display monitor installing graphics card
  1. When you say "new" card, is the card "new" or used? Most likely issue is bad card or power supply issue with the card.
  2. Some things that I could think of is the boot settings. Is there an option for PCI Express Graphics? If there is then select that. The second thing is that try using different connectors if you have like DVI, Display port, VGA. The third thing is try resetting your CMOS. If you don't know how to clear the CMOS, you can look at the instructions here. http://www.manualslib.com/manual/432348/Asus-M5a78l-M-Usb3.html?page=29#manual

    Is the computer able to display when going into the BIOS settings but not displaying when going into the operating system?
    If answer is a yes then It can be the OS, BIOS settings or RAM configuration maybe even HDD or SDD boot order and config.
Ask a new question

Read More

Graphics Cards Monitors Motherboards Displays