DRAM LED / No Post - Multiple Tests! Please Help!

Ran into some issues while testing for post on my brothers new gaming pc, hopefully somebody can figure out what the main issue is so we can avoid multiple hardware returns and shipping costs.

Full Build for Reference - http://pcpartpicker.com/p/xQMsGX

Here are the hardware components we were using while testing for post.

(MOBO) - ASUS Z97-A LGA 1150 Intel Z97 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
(CPU) - i5 4690K
(RAM) DDR3 Corsair Vengeance Pro 1866mhz (2 x 4GB)
(PSU) XFX TS 650W 80+ Gold Certified ATX Power Supply

THE PROBLEM: Everything was assembled correctly, 24 pin connector and CPU power connector plus ram was seated in its correct spots A1/B1. I powered up the mobo to test post and the CPU Led flashes red one time and immediately turns off, followed by a permanent red DRAM Led and nothing on the monitor.

I researched countless posts and tested each RAM slot individually with multiple sticks of RAM including new and old (that worked before) and nothing seemed to work, took the cpu out and placed it back inside to ensure it was secured correctly, still no fix.

MY APPROACH: At this point I figured it was faulty ram or the motherboard was faulty, so I brought his components (i5 4690k & Corsair Vengeance Pro) to my PC and decided to see if the results were similar on my PC.

Here are my components for the test..

(MOBO) - ASRock Z87 PRO3 LGA 1150 Intel Z87 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
(CPU) - i7 4770k
(PSU) - EVGA 120-G1-0750-XR 80 PLUS GOLD 750 W

I first tested his RAM (DDR3 Corsair Vengeance Pro) with my CPU (i7 4770k) and it booted correctly, right to the login screen. So the RAM can't be faulty.. checked the bios and both sticks were recognized in their correct DRIMM slots.

After that I placed his CPU and RAM inside my PC and booted up and got the following message..

"The following Channel memory did not pass CPU memory test, Please remove the memory then plug again. Channel A"

I then removed the ram and tested the slots with my ram and got the same message, tried the other slots and still the same outcome. I pressed F2 to enter my bios and saw that 8GB was detected on one channel, channel b1.

I'm beginning to think his cpu is faulty, but i'm hesitant because so many people say it's most likely the mobo or ram failing but neither seem to be the issue because my motherboard works fine and the RAM works with my mobo but his CPU seems to be the problem.

Can anyone confirm my issue, or possibly shed some light on my problem? It's been a long day trying to come up with a fix or any type of solution/conclusion.

Thank you for reading!
Reply to Austin_Dish
3 answers Last reply
More about dram led post multiple tests
  1. Did you plug the case fans into both the molex off the psu and the board? If so undo the molex connector
    Reply to Supahos
  2. Supahos said:
    Did you plug the case fans into both the molex off the psu and the board? If so undo the molex connector


    We were testing for POST outside of the case before assembling it inside and ran into these issues.
    Reply to Austin_Dish
  3. Same problem, but on Asrock Z87E-ITX. But it sound so similar...
    I write inspect of the post is old, because I think It could be of some help for somebody else.

    My motherboard started to show the error on POST:
    the following channel memory di not pass CPU memory test.
    please remove the memory then plug again
    Channel A

    I had G.Skill TridentX, but I bought 2 Corsair.
    I noticed I had the same problem on the same channel also with Corsair.
    I started to exchenge modules and despite wich module I used, I always had problem on channel A. No way.

    I wrote to Asrock. As always they replied (great support everytime). They suggested to:
    * unplug the mobo and keep it unplugget for 10 minute
    * remove the RAM modules
    * clean the modules with a rubber.
    * clean the slot A with rubber or something that could fit (i tried in different way, than clean with compressed air).
    * clear the CMOS.
    * plug the RAM and power and start.
    No way. Same problema on Channel A with both RAM types.

    Reading different posts, somebody wrote someting related to CPU. mmm... interesting.

    I removed CPU, and .... ops, There was something on one pin.. It seemed (but it was very very very very smal, that a pin orientation was not correct). Th pins are all oriented diagonally with respect to CPU socket borders. One pin was parallel, so in a different orientation. I had to use a magnifier and a very powerful light.

    I tried to move the pin with a small plastic part, very smal, usign the magnifier, tring to orient the pin diagonally. I did it. Then I cleand the contact surface of the CPU. Then I plugged the CPU on the socket and I noticed also that plugging the CPU (the way i did it) could cause the pin bending.(exactly that pin).. so maybe the problem started when I pluged it the first time.

    I put the cooler, and power connections... and start....

    The Channel start to show RAM modules, either G.Skill and Corsair...
    Now it works great.

    I hope it could help.
    &
    Reply to andreazauli
Ask a new question Answer

Read More

Motherboards