External HDD is not working. Not showing up on Computer Management and yellow /!\ symbol in Device Manager.

Hello,

On Monday my HDD stopped working in my computer running W8. I plugged it in one running W7 and it was not recognized either. Next, I plugged it in another PC running W7 and it worked. I created a back-up and kept trying to make it work.
Uninstalling and updating driver did not work, manually deleting it from System32 and re-adding it did not work either.
(https://imgur.com/m16rx6n) The drive was not showing up on Computer Management, and it has a yellow /!\ icon in Device Manager. It gives the error code "Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory. (Code 38)"
When plugging it in, I do hear the jingle, but no notification about drivers or AutoPlay shows up.

Finally, I updated to W10 and it worked again!
Now, Thursday, it stopped working again. If possible I'd like to avoid re-installing Windows. It still works with the W7 computer.
Claiming warranty for the drive is not possible, using other cables do not make it work, and I have no equipment to disassemble and plug it directly.

Thanks for your help!

https://imgur.com/m16rx6n

Update: All other kinds of USB hardware (Mouse, Keyboard, Printer) do work. Power is being administered, because the HDD spins when plugged in. The HDD and USB Flash Drive work on all other computers, except mine. No use in uninstalling and updating the drivers from Device Manager. Laptop model: ASUS-K501LX
4 answers Last reply
More about external hdd working showing computer management yellow symbol device manager
  1. It sounds like the drive may be failing. You were smart to back it up after getting it to work on the W7 computer. Have you tried different usb ports on the W10 computer? Does a flash drive work on the W10 computer usb port you were trying to use with the HDD?

    Installing it directly into the computer usually isn't an option. Many external HDDs are hardware encripted, meaning they will only work in the case (or another identical one) that it came with.
  2. mjslakeridge said:
    It sounds like the drive may be failing. Have you tried different usb ports on the W10 computer? Does a flash drive work on the W10 computer usb port you were trying to use with the HDD?


    The drive is not failing, since it works perfectly on other computers (Tried another W10 today).
    Yes, no other USB ports work. Tried 3.0 and 2.0
    I just tried with a flash drive and it's having the same issues.
  3. Hi there ReneOv,

    This should be either a driver or power(less probable) related issue as the drive works just fine on other systems.
    You can go to your MOBO's website and update your latest drivers.
    Also, have you tried uninstalling the device from Device Manager? In case you haven't, you can try that. Uninstall -> unplug the device -> reboot -> plug it back in.

    It will not hurt to attach the drive to one of the ports on the back of the computer case. They tend to provide more power as they are attached directly to the MOBO.

    Cheers,
    D_Know_WD
  4. This is actually a laptop. I tried all other ports with no use. Yes, I've definitely tried to uninstall, and also try updating it (Says it already had up to date drivers.)

    Here's the list of drivers available for my laptop: http://www.asus.com/support/Download/3/788/0/1/cgSxMlZWmrvUbTYS/45/
    Couldn't find one that would fit the situation.
Ask a new question

Read More

Device Manager Computers Storage External Hard Drive