Solved

solid red power button on z10pe-d8 ws

please help i bought a new ASUS z10pe-d8 ws motherboard but when i hooked up the power supply the intergated power button is a solid red and doesnt respond, tried this with more than one psu 800w & 1200w but i doubt thats this issue.

Kind regards.
Reply to Curtis_3
3 answers Last reply Best Answer
More about solid red power button z10pe
  1. Sounds like a defective board. Call Asus.
    Reply to Sleetz
  2. Best answer
    i`m going to take it that you did take the time to read all the way through the manual that came with the new motherboard you bought. I only say this because about 50 to 60% of the time the honest answer is no i have not.

    If the case it`s self explanatory as why in most cases the user has not and why the board is not working right or powering up.

    Due to a lack of power connectors from the PSU to all the power points of the motherboard that require power in order for it to work right and post, and positions on where you exactly need to place ram or memory modules into the slots provided for them on the motherboard in the right positions based on the amount of memory sticks used.

    Because failing to check that results in the board also not powering up right and posting.
    If you read the manual the red light means the board requires more power, meaning you didn`t read the manual in most cases.

    It means that one of the extra atx power blocks is not connected from the psu to the motherboard, for example you may have only four of the pins connected other than the eight required.
    Or missed them out.

    If the board has multiple led lights for the Pci-e graphics card, CPU, Memory, any single light still lit indicates what section of the board you should be looking at, in your case since the red light is lit on the board for power.

    You have a power problem, or a lack of power and why the led light is a fixed lit red. So power to the motherboard from the Psu needs to be double checked. And is the cause as to why the board is not posting right, or fully in most cases.

    Most likely the extra atx 12v eight or four has not been plugged in to the motherboard from the psu.
    Go have a check.
    Reply to Shaun o
  3. I have the same problem!
    All power cords connected. Rams is correct places. Tried with one and dual cpu on socket. Same result. Just red led on power button on. Nothing else.
    Any help will be appreciated. System specs is below. Sorry for bad english.

    Case: Phanteks Enthoo Pro
    Motherboard: Asus Z10PE-WS DUAL LGA 2011 V3
    PSU: Cooler Master Silent Pro 1200 Watt 80+ GOLD
    CPU: 2X Intel Core Xeon 2683 V3
    Ram: 64GB DDR4 RDIMM 2133 MHZ 8x8GB Crucial ECC Registered
    CPU Cooler: 2X Enermax ETS-T40fit White Cluster
    GPU: Nvidia Quadro 6000 6GB
    Reply to Shirinoff
Ask a new question Answer

Read More

Asus Power Motherboards