Major Problems With BIOS and Overclocking

Hey guys!

So I'm having some serious problems with my new personal rig that I built not too long ago (About a month). My first issue was with the BIOS. I can access the BIOS by pressing F2, but as soon as I move my mouse while in the BIOS, it freezes and I cannot do anything at all. Then, after removing my CMOS battery and restoring the BIOS to it's original settings, I got it to work (The mouse froze, but the arrow keys let me navigate it).

So now that I got it to work, I figured I'd OC my 4690K to 4.4Ghz at 1.24vcore. So I decided to run Planetside 2 to see if my temperatures would go sky-high. Turns out that it made the game run horribly with extremely low fps and distorted audio. So I ran Valley benchmark and it also ran horribly. Now I tried to access the BIOS to restore my clock and voltage to stock, and guess what?

The BIOS freezes as soon as I move the mouse (Also rendering me unable to use the arrow keys this time)

I know this might be tl;dr for some of you, but can anyone help me out? All help is appreciated

My specs:
i5-4690K (4.4Ghz 1.24vcore ATM)
Hyper 212 EVO
Gigabyte GA-Z97MX Gaming 5
8gb Kingston HyperX 1600Mhz
128gb Corsair Force LX SSD (Only had Windows)
1tb Western Digital HDD (Games and everything else)
Radeon R9 280
Thermaltake Core V21
Corsair CSM 650w
Windows 7

All help is appreciated
2 answers Last reply
More about major problems bios overclocking
  1. reflash your BIOS to the latest version, should do the trick.
  2. Reset cmos, flash bios with latest, update ur drivers. Just try not oced first and see if it's running slow.
Ask a new question

Read More

Overclocking BIOS Mice