Need Help! computer won't post. no idea what it could be.

Warning a lot of back story

Okay so. I bought a new 390x to replace my 280x crossfire setup. All was well for about 2 weeks.
I then decided to upgrade to Windows 10.
I formatted all my hard drives after saving anything I wanted to keep in an external and started my install on a USB key. All was well, I ran into a little trouble with the type of partition I needed to install the windows on but I resolved that.
Anyway after the installation got underway it said it needed to restart. Computer restarted and it ended up back in the beginning of the windows setup, I was annoyed so I decided to try it again later. Turned off my computer and went to dinner. After that I came back to the computer to continue and poof no more post.
The motherboard lights up and everything, but nothing turns on. No USB no video and no beeps. So naturally I started to check all my components worrying it was my motherboard. I tried it with one one stick of ram, trying each in every possible slot (4) then changed out my visiontek 390x for my xfx 280x and still nothing. At that point I thought it was my psu. So I went out and bought a 850w 80+ gold thermaltake to replace my 750w 80+ bronze evga.
Having high hopes I switched out the psu and boom, nothing.
After some complaining and bitching I ended up trying the computer with my second 280x which is a sapphire dual x. And voila the computer posts and boots. Wow so I install Windows 10 and everything is good. I sent back the 390x for a replacement thinking I just had shitty luck and both the 390x and the xfx 280x died (even though the xfx was working before and was just sitting in a box for a fortnight) anyway replacement 390x comes in today and I install it and same thing no post....
So what do you guys think? Is it my motherboard
Just for reference in running a 3570k on a Asus p8p67 deluxe motherboard.
Thank you in advance guys, and sorry for the long read.
1 answer Last reply
More about computer post idea
  1. Hmmm. Head scratcher. So you install the graphics card in the same PCI express slot? Maybe clear your CMOS out and see if that helps. It could be the motherboard is still looking for your 280's and when they aren't there starts freaking out. I'd start there. It could be related to the partition issue. No display usually means a problem with something in the video department. Did you try just plugging the board directly to the monitor? If that doesn't work then try clearing CMOS. Other than that, I'm stumped.
Ask a new question

Read More

Computers Motherboards