System freezes, potentially a faulty SSD?, diagnosis help

I have been diagnosing this problem for the last 3 days without much progress. I am hoping that someone will be able to have a look over my testing and hopefully something will jump out that i have missed.

A few days ago my system BSOD with a memory management failure. I reset and checked the log to find it was a kernal power failure. Then my whole system froze without a BSOD about a few minutes after logging on.

Windows keeps on freezing, sometimes during boot, sometimes after logging in, sometimes in safe mode, even during install.

I reset bios to defaults, my temps were cool at 35*C.
There is quite a lot to read here, so i will try and be succinct. When i say frozen i mean everything form mouse to keyboard to screen. No hdd activity, have to reset.

Steps i have taken in order:
-Booted into safe mode to run some tests, computer freezes
-Ran memtest for 21 hours with no issues detected.
-Rebooted into safe mode with cmd.
-Ran check disk /f /r which froze on stage 5 (verifying free space, no hard drive activity), I rebooted.
-Ran sfc/ scannow which froze at 89% (no hard drive activity), I rebooted.
-Booted into safemode with cmd and ran malware bytes. MWB hung on checking system files. I rebooted.
-Opened up the computer, checked my motherboard for damage, burned parts, overheating, checked my wires etc. Found nothing wrong.

-Load up Windows from disk and attempt startup repair. It finds nothing wrong with startup.
-Load up Windows from disk and attempt to do a system restore to a previous point. I picked the earliest restore point. Windows reported error 0x8000ffff and failed to restore. I attempted this twice with the same error.

-Flashed my bios to the latest version using USB flash.
-Decided to do a reinstall of Windows. So i pop in the disk, load files, format the drive and install.
-No problems, Windows installs and i boot into new Windows. Then i remember that i forgot to load my raid drivers. I did not spend much time in Windows before rebooting to reinstall, so i don't know if it was stable or not.
-Load up Windows from disk, load raid drivers, format my C drive, computer hangs and locks me out. Windows install freezes so I turned off the system (no hard drive activity).

So where do i go now? I think it is an SSD failure so i have just bought a new one from Samsung and am in the process of RMA'ing my 'faulty' one.

Before i do that though, can anyone else think of things to try? maybe i have missed something crucial? I would love some feedback :)

Specs:
AMD FX 8350, Sabertooth 990x r2, radeon R280X, 16GB corsair XMS3, Corsair 750W PSU.

1x Samsung Pro SSD - Only windows is installed. This is the hard drive i ran all my tests on.
1x Crucial SSD M4 for all my programs - No issues with this drive
2x RAID 1TB WD drives for data/media - No issues with these drives
6 answers Last reply
More about system freezes potentially faulty ssd diagnosis
  1. You have 2 sticks of memory in there?
    Did you try using just one of them, and if it still crashed try using the other one instead? Also tried using different RAM slots (all available with just one stick of RAM)?
    Did you try removing unnecessary USB devices?
  2. I did unplug all unnecessary usb devices before testing. I have 4 sticks of RAM
    Tonight i will remove all my ram bar 1 stick, i will unplug all my hard drives except my C Drive and i will attempt another clean install.

    In terms of tests like chkdsk and sfc to run though, are there any others i can do?
  3. Clean install failed with 1 stick of ram and C drive only.

    So i removed my C drive and installed windows fresh onto my programs drive. Goes without a hitch and boots into windows fine.

    Bought a new SSD today, same as my old C drive and reinstalled windows onto it. Everything ran fine and booted into Windows.

    I plug in my programs drive and format it ready for some programs. I then restart and plug in my data drives. The computer runs a disk check (without me asking it to) and then boot into Windows. Then i get crashes and system hangs. No hard drive activity. Looks like its was my data drives causing all the problems.

    So, how to i solve this? How do i clean my data drives without formatting? why did windows run a check disk without my permission?

    any help would be greatly appreciated.
  4. Because either one of them is about to go belly up or the RAID is damaged. Try removing one drive and copy the data from the remaining one. Or, if you dont need the data, just break up the RAID and redo it.
    How is it configured anyway? Just a software RAID over the Intel chipset or do you have an extra controller?
  5. My RAID status does say 'critical' on raidxpert and in the RAID ROM. Trying to work out which drive is faulty though is difficult.

    At the moment i am copying all my data to an external hard drive so that i can just format both RAID drives and build the array again.

    Im running the AMD controller off the bios. Its not software RAID but bios/motherboard raid.
  6. 1: kd> !error 0x8000ffff
    Error code: (HRESULT) 0x8000ffff (2147549183) - Catastrophic failure

    I am not sure I would run raid on the samsung SSD. (I assume you are not and it is running on a primary sata controller)
    (also check the cables for your OS drive.)
    you might also see if there is a BIOS update for your motherboard and check for firmware updates for your SSD

    if you have a memory dump, put it on a server and post a link.
Ask a new question

Read More

SSD Blue Screen Storage Memory Management