Locked at 60fps without vsync??

Hi everyone,

Got this weird situation going on and I know what all your first thoughts will be as it was mine but I am locked to 60fps even though I have turned it off in the nvidia control panel, I have tried every mode as I usually just leave it on adaptive. I uninstalled my drivers and tried a few older ones and everything may seem ok for a few mins but then I run a benchmarking test and I get 60?? I have tried multiple test softwares, in case that was the problem but still I'm at 60 fps. My next thought was that maybe I have some drivers left over from a previous update so I sweeped all the video drivers and guess what? Still at 60fps lol

I recently made this PC and everything should be fine so I just don't understand.

My PC seems to be having issues overclocking which maybe related? I don't know... I have issues overclocking my gpu and cpu for some reason. For instance when I try to overclock my Titan, I'm lucky to get a 60 ghz increase, yet it's watercooled and the i7 4820k 4 core fails nearly all overclock attempts and always auto corrects it with the turbo off and if I do a overclock with out turbo it still won't overclock successfully.

Something just really feels off

4820k
Gtx Titan
Sabertooth x79 mobo
16gb corsair vengeance quad
120gb Samsung evo 850 SDD
2tb HDD said seagate
Corsair h100i
Magicool gpu cooling system
EK FC waterblock
EK backplate
750w powercool PSU (maybe the issue???)

Please note my temps are all great

Thanks for looking
2 answers Last reply
More about locked 60fps vsync
  1. Do you have rivatuner installed? That may be limiting your fps, also turn adaptive to off and set off in the game/application.
  2. I use precision x 16, (cpu bios) and as I stated, I have tried all the modes and there is no difference
Ask a new question

Read More

Graphics