Sabertooth 990FX R2 Won't see R9 290x GPU

Just got a Sabertooth 990FX R2 and it won't see my R9 290x GPU. when i go to boot I have a boot device failure light stay on and also a vga failure light comes on as well. I also have the current bios update. I have verified that the board and slot are good by trying an old card which worked fine. I have also verified my new GPU in another computer that happens to have the exact same MOBO and works just fine. I have spoken with ASUS support and they are useless. Any help would be appreciated.

My full computer specs are
Sabertooth 990FX R2 MOBO
Sapphire R9 290x GPU
G. Skill DDR3 16GB
AMD Phenom ll x 8 FX 8320
Corsair 850 Watt PSU
5 answers Last reply
More about sabertooth 990fx 290x gpu
  1. Have you tested different PCIe slot and still no go?
  2. Thanks for the reply. And yes I did with no luck
  3. When I plug in the old video card it comes up with a message that says "the current bios settings do not fully support the boot device" then it asks me to change can settings. I Have tried to change a few settings with no luck.
  4. No other idea, then... Try RMA-ing the board... or CPU.
  5. .
Ask a new question

Read More

Sabertooth GPUs